Vero 4k+ does not boot correctly, black screen


I am experiencing an issue with Vero 4k+ where the system goes to a black screen after some seconds upon boot.

It is a bit difficult to explain: the Vero is attached to a tv via HDMI, no external peripherals. As I attach the power cable, the system boots and “Please wait” is shown on the screen. Then, the OSMC logo comes up and that’s where the problems start… sometimes the system boots to the Home screen and it works normally for some time… maybe a minute, or 5. Sometimes it just stops working and and the “no signal” logo is shown on my tv.

I haven’t installed new add-ons recently and also I haven’t updated the osmc recently.
I also tried other HDMI cables. No change.

I managed to get to the log settings, activated the logs and I uploaded them here, in one of the instances when the system booted.

Do you have any suggestion on the cause or solution?

I just signed in today to look for this issue. My Vero 4K+ was non-responsive for about 5 minutes that I know of. I just came down to eat lunch and watch something, who knows how long it has been frozen. I unplugged it and when I plugged it back in, the same behavior you described. I haven’t updated it in forever since I am still running Kodi 18.

Just letting you know you aren’t alone!

So if I understand correctly, you unplug the Vero when you do not use it? I don’t know if it’s the same problem but I noticed on one of my Veros that when I unplug the power connector from the Vero itself but keep the actual PSU inside the power socket and then reconnect the cable to the Vero, it sometimes doesn’t boot properly. If that’s what’s happening to you, I’d suggest unplugging the PSU from the power socket, instead of unplugging the connector from the Vero.

You’re on a very old version of OSMC and missing out on quite a number of improvements. Is there a specific reason you’ve chosen to stay on an old version?


I don’t know if you are referring to my version of OSMC or to marriedman’s… anyhow, I haven’t used the device for some months… left it plugged in the TV (with power cable connected) and just two days ago I thought I could watch something. And then this happened.

If I’d be able to update the OSMC I would! Now I left the device and PSU all disconnected )also PSU from power socket) for 1 day, turned it on again now and nothing changed… usual behaviour.

Actually both of you use a very old version.

Do you think you can get it booting up again with screen one more time? Then you could do the following:

Go to My OSMC → Updates → Manual Controls → Apply Hotfix.
Enter ucawobahij and proceed.
Then go My OSMC → Updates → Manual Controls → Scan for Updates

Alternatively if you have SSH access we can give you commands for that.
But also as we have seen that recently did you tried another HDMI cable/port and also cleaned the contacts with contact cleaner?

Sorry so long in between site visits - I only think about this when I get to sit down and watch something.

I ended up factory reseting and upgrading to the latest. I stayed on v18 because the GUI/Theme that I love is not available for v19. Though I have been tinkering with Emby so that my parents can stream videos from my server, so I went ahead and installed the EmbyCon plugin and just used an Emby theme. Works well enough for me.

Things seem to be working now. Well, I have stuttering video playback, but that is another topic!

Hi! Sorry for the very late reply.

I have ssh access! What commands to I need to run?

sudo apt-get update
sudo apt-get dist-upgrade

And then follow the commands at the end of the error message

It seems that even ssh does not work?
I tried rebooting osmc by removing then attaching again the cable. The system boots and I am able to ssh into it. However, I have issues rugnning this commands… I made two trials:

sudo apt update


sudo apt-get update

Do not seem to work, see code and output here.

Second trial:

sudo apt-get update --allow-releaseinfo-change

So I changed to this, see code and output here, that however, results in lost connection to the device via Putty. It also disconnects completely from my LAN and I need to reboot it via power removal to ssh again into it.

Any further suggestions?

Sounds like a power supply problem.

You could try a reinstall from new Image but may have to check for a new power supply.

Hi! Sorry… just went back some days ago to the place I keep the Vero and I tried it again.
I updated to kodi 19.4 (2022.03-1) via USB after downloading image.

The device is now at the default settings… sometimes it stays on for some time; other times it presents the usual issue. I would also like to add that when the image on screen cuts to black… the power is still available to the vero (it powers a USB keyboard and it has its red led lit)

I uploaded a recent log here; if you happen to have any suggestion you are wecome to share!

Do you mean the LED on the front of the device?


Yes; but unfortunately it does not always behave in the same way.
Sometimes the front LED is on when the screen cuts to black (as I mentioned above) and some other times it turns off. In both cases, the only solution I found to make the image reappear on screen is to re-boot the Vero by power cycling it.

Another log of recent activities included here

I also tested the Power Supply with a multimeter and to my eyes it provides a clean and constant output voltage

Do you have an alternative 5V, 2A power supply you can test with?


Unfortunately, I don’t have a PSU with that output and that connector. But I want to try with USB as soon as I manage to get a A-A cable, you think it can help?

Did you test it under load? Vero pulls up to about 750mA while booting.

If it works, you know the problem is with the PSU.

1 Like

I am back here and I managed to retrieve a USB-A to USB-A calbe.

It works! Now the Vero 4k+ has been up and running for a while.
How can I retrieve another PSU?

You need a PSU rated at 5V, 2A with a 5.5mmx2.1mm barrel plug ‘type M’ (centre +ve).

1 Like




1 Like