Vero 4k+ doesn't play since last update yesterday

Hi all,
since yesterday’s update I a unable to play anything (No video, no music). The box only shows the busy indicator, eventually the 1st frame comes up, with music it plays some seconds, then pauses some seconds, continues then for some more seconds. In “top” I see the CPU using permanently 30-60% when trying to play something.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for looking into this. The logs are here:

You should disable sync playback to display. Not sure if it will resolve everything, but it certainly negates the passthrough of your audio.

Didn’t help - the 1st frame came faster, but then it was frozen.
Last message was: CVideoPlayerAudio::Process - stream stalled pts:2.000 clock:3.163
Two minutes later I cancelled the play.
I believe. it has some trouble to access the files on my NAS.

I think there’s an issue with the latest kernel and ethernet. Do you get a better experience using WiFi?

You might like to remove this line from /etc/apt/sources.list if you want to avoid surprises:
deb buster-devel main

1 Like

yes, switching to Wireless did the trick.

It would be good if you could run an iperf test on Ethernet so we could check the values.

Sync Playback to Display won’t do anything on Vero 4K/4K+ – we override this setting.

I’ll see if I can do this - not easy because my other *ix system is an openbsd and I have to look for an iperf package to set up client-server connections

Got it:
root@osmc:/home/osmc# iperf -c tau

Client connecting to tau, TCP port 5001
TCP window size: 85.0 KByte (default)

[ 3] local port 60876 connected with port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-10.0 sec 701 MBytes 588 Mbits/sec

The iperf-Server is connected with 1000MBit network.