Vero 4K doesn't power up

I’ve had my Vero for a little longer than a year now (bought it in May 2017). I recently bought a new television and moved the Vero to another room. Unfortunately it doesn’t power on any longer. When I plug the device in the wall, the power LED flashes red once and then there’s nothing. Also tried to boot with an USB stick plugged in, but the same thing happens. Does this mean my unit is toast or is the power supply at fault here?

I have this PSU lying around to try, but I’m not sure if it’s compatible:

Pin config of the jacket looks right, voltage is OK.
If it fits (!!!), give it a try … but at your own risk.

If it should work, treat it as a workaround, only, till you get a correct power supply.

Putting @sam_nazarko on this post, so he can give further advices what to do and follow up.

Just an additional question: How long did you wait for the Vero 4k to come up and bring some signs of life to the display? Just give it a minute or so.

I’ll hold off on trying the other PSU for now. I did leave the Vero attached to the television just now, for more than ten minutes. But nothing happens after the initial flash of red light.

That PSU is rated at 1A. Not enough. You need 2A.


Have you tried connecting to vero4k via ssh or pinging the IP address?

Could be an issue with the display.

Thanks Tom.

Do you have a USB cable (A-A) lying around?
Disconnect the PSU and try and power it via the white USB port from a PC.


I don’t unfortunately, but I’ve ordered one. Will report back with the results.

I finally received the right cable and just tried to connect. Unfortunately it doesn’t power up and exhibits the same behaviour as with the PSU. So brief red light blinking and then nothing. This is on a MacBook Pro with Thunderbolt 3 ports and a connection hub, so I could try to plug it into the MacBook Air with normal USB ports that’s lying around here somewhere, if that might make a difference.

But it doesn’t look good, right?

It might help to try a reinstall. See Reinstalling OSMC - Vero 4K - OSMC.

And that did the trick. I tried a reinstall before, but for some reason it didn’t work at the time.

The Vero now powers on using the USB cable, but also using the PSU. The only thing that seems to be broken is the blue LED, red is working, I think.