Vero 4K+/EGreat combo does not switch to 24Hz playback after TV is switched off/On. Works with RPi3/EGreat

So, my Vero4K/EGreat is not switching to 24Hz playback if TV is switched off/on. I have to mess around with the EGreat to get back 24Hz but then I get a black screen saying resolution not supported on switching back to the Gui. A few more EGreat button clicks and GUI comes back. Only a full system reboot will get it working properly again - only to be all lost when TV is switched off/on.

NB, this is with the AVR switched off. If AVR is on, then no issue. I also have Sync to Display disabled and tried Lock HDM enabled / disabled.

I would normally suspect the EGreat as the Vero is fine plugged directly into the TV. But I replaced the Vero with my RPi3 and works flawlessly (with AVR off).

Logs after a full system reboot and then after TV switched on/off here:


Hopefully the issue is now addressed
I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sure will try out tonight. Apologies i didn’t quiet realise this was the issue the patch is all about.

Sadly, the patch did not work :frowning:

Anything else I can do//try?

Do you mean it didn’t solve the problem or it didn’t work at all?

Could you please make a new log:

  • reboot without AVR on so everything works
  • turn off TV and note time when you did it
  • turn on TV and note the time when you did it

Without the times, It’s difficult to see what’s going on from the logs

I meant it did not solve the problem.

  1. Power cycled it all and rebooted with AVR off
  2. Played a movie - all good.
  3. Switched off TV @ 20:27
  4. Switched on TV @ 20:28
  5. Played movie again - 60Hz playback

Logs :


Vero is correctly reading the EDID from your screen when it’s on. This includes 24Hz modes.

When you restart the TV, Vero knows this and re-reads the EDID but it is a much reduced set of screen modes - no 24Hz modes - probably being generated just by the Egreat. It’s possible that the EDID sent by your AVR does include 24Hz hence why it works with the AVR on.

We will try adding a short delay between vero detecting an HDMI change and re-reading the EDID.

I think this already happens. I’ll check latest AML drop to see if anything’s been tweaked

Thanks but why does the RPi3/OSMC work? I can post the logs for that too if it helps.

EDIT : Also, the Vero works fine on first start if I remove the AVR from the equation by disconnecting it. It’s only on the TV restart that it goes wrong.

Or could Vero ignore the TV restart and keep it’s initial settings?

PS, I’ve never been a fan of introducing sleeps etc int code to get over race conditions and the like etc - just causes more issues down the line :frowning:

Different platform — so not an exact comparison.

Give us a few days to work on some improvements and we will make them available for testing

We don’t need to sleep magically; but rather wait for falling edge on HPD; if I’ve interpreted things correctly



1 Like

Noted with thanks. Appreciate both yours & Graham’s support on this.

RPi3 logs here if it helps :

  1. Power cycled it all and rebooted with AVR off
  2. Played a movie - all good.
  3. Switched off TV @ 13:04
  4. Switched on TV @ 13:05
  5. Played movie again - all good

I think you are right - it reads EDID twice (or until it gets 2 reads the same?) but kodi needs to wait until kernel has got a sane EDID.

Can’t we just wait for hpd_state (via sysfs) and keep polling that like we do for updating resolutions on hotplug?

Ok, I am not convinced the Vero is to blame here. I did a bit more testing:

Same as above, but this time, instead of switching outputs on the EGreat to get 24Hz working again, i rebooted the Vero fully expecting that to work as it would re-read the EIDE right?

Nope, still 60HZ playback. So that points to EGreat unless I am mistaken in my understanding of how this stuff works - not an expert so making some educated guesses :slight_smile:

Have you tried to bypass whatever the Egreat is to narrow down where the problem really is? (You’ve never told us exactly what the Egreat is!).

It’s an HDMi Audio/Video Splitter like the HD Fury. See here : Using my Bluray player as an AVR - #31 by sarit.shah

Yes, i have plugged the Vero directly into TV and all good.

That suggests the EGreat is not reacting to the TV being turned on (as it should), re-reading the TV EDID and repeating the display caps to vero. From the logs, vero is correctly reacting to the TV being turned on but it can only read the EDID served up by EGreat.

Yes I tend to agree. The only way to make it read the EDID is by flicking the buttons to switch outputs (3 options).

I’ll check if there is a firmware update but very little support for it. Should have gone for the HDFury. Lesson learnt.

Read a post by Sam somewhere stating that have to reboot after enabling Lock HPD setting. I hadn’t done that when i tried it so enabled it again & rebooted.

It works! Playback at 24Hz after TV is switched on/off!