Vero 4K+ ethernet port worn out

Hi Forum,

unfortunately, I found out that the ethernet port on my Vero 4K+ is worn out, any ethernet cable does not connect properly because the plug is not locked anymore. I can play a little bit with the plug and establish a connection but this does not last for long.

I have opened the device and found out that the port is soldered directly to the corresponding IC and, due to the fact that I have not the necessary soldering device, I cannot replace the port easily.

Before I start to try to fix the problem by applying some hot glue to the plug, I like to hear other opinions. May be there is another, better solution to my problem.

Due to the fact that the Vero 4K+ has only USB 2 port, my best guess is that any USB to ethernet converter does not give the necessary gigabit ethernet speed.

Thank You for reading and providing input.

Hi

You could try another cable. Break the clip off so it slides in but doesn’t click

Sam

It gets enough speed for any content your likely to play. I use one with my Vero (non plus) and it lets me play larger rips that I can’t through the built in 10/100 adapter. The trick is finding one that is compatible as there isn’t a supported adapter list that I know exists. I managed to find mine by searching Amazon for ones that were not Realtek chipset based and which contained customer reviews that stated they had a plug and play experience with Linux. I would offer up the model of the unit I have but it is an Amazon Basics model that is no longer sold.

1 Like

Thank you for your input. I have tried different cables but I will first of all try out Sam’s suggestion. Also I think that I still have an USB 2 adapter that came with an Asus notebook.
I will be home in about three months. At the moment I enjoy traveling after two and a half years of Corona restrictions here in Thailand.

Sorry to come that late back to my problem, I was travelling for 4,5 month.

I could solve my problem with a little hot glue which I applied to the ethernet plug and the outside of the Vero 4k+. That fixed the plug and holds it in stable position.

I have tried out a HooToo USB 3 adapter with a AX88179_178A chipset. The USB hub was recognized immediately by OSMC and I could establish an ethernet connection with this device easily.

Maybe this helps other folks.

1 Like