Vero 4K: Expert help to analyse crashlog output?


please help me to analyse the attached chrashlog from Sad Face.

Here is short explanation of the logged content.
I’m running my python script: from Autoexec Service Addon.
This script is interacting with Kodi via Json RPC to loop the first entry of the playlist:

  1. play the first video entry from play list
  2. detect the stop event during runtime
  3. goto playlist index: 0 to replay the first entry of the playlist.


  1. What causes the crash with Sad Face?
    My guess is that I’m triggering a race condition by sending goto index 0 at the end of the processed first video entry. At that point the second playlist video entry is processed simultanous?
    As mentioned it’s just a guess.
    Please let me know which logging detail describes the crash cause.

  2. How is the error handling after Sad Face organized?
    Restart of the mediaportal or restart of OSMC?

  3. What is the reason that the restart of the RPC server instance fails after restart?

If a sad face appears, Kodi is restarted by the watchdog, nothing else is restarted
Kodi appears to be crashing from a segmentation fault.

Can you give us the output of md5sum /usr/osmc/lib/
Have you replaced this file at all

Can you try:

sudo apt-get install --reinstall vero-libamcodec-osmc

and see if this helps?

Thank you for your reply.

Can you give us the output of md5sum /usr/osmc/lib/

Yes, it returns:

b2eabe8e0e5ad6858fd4692f73dd528d  /usr/osmc/lib/

Have you replaced this file at all

No, I did not replaced this file.

Can you try:
sudo apt-get install --reinstall vero-libamcodec-osmc

Yes, returns with:

Unable to locate package vero-libamcodec-osmc

please see below:

osmc@osmc:~$ sudo apt-get update
Hit:1 bullseye InRelease
Hit:2 bullseye-updates InRelease
Hit:3 bullseye-security InRelease
Hit:4 bullseye InRelease
Reading package lists... Done
osmc@osmc:~$ sudo apt-get install --reinstall vero-libamcodec-osmc
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package vero-libamcodec-osmc

Did you mean this package, which is part of the apt list?


Yes, sorry.

Ok, I will report.

Hi Sam,

unfortunately, reinstall of libamcodec-osmc did not help. Please have a look into the details:

Please tell me, if it would help to provide an python script example to reproduce the crash.

Sorry for the late response. Thanks for tagging me in the reply.

The updated logs don’t seem to show Kodi crashing anymore.

/home/pi/Multimedia/Video/HAG_4K_TIMELINE_MEDLEY.mp4 doesn’t seem to play and gives a video error. Have you tried playing this file manually?

From the /home/pi naming, I wonder if you copied over the Kodi userdata from a Pi to a Vero? If you did so, I suggest removing guisettings.xml as this cannot be moved between different types of devices and will cause playback problems.

Thank you for your reply.

Have you tried playing this file manually?

No, python script calls “Player.Goto” playlist index: 0 via JSONRPC
From log file:
2024-04-08 22:03:37.401 T:2917 debug <general>: JSONRPC: Incoming request: {"jsonrpc": "2.0", "method": "Player.GoTo", "params": {"playerid": 1, "to": 0}, "id": 14}

At this time Index 1 of the playlist (Film02_1920x1080_Countdown-31098.mp4) is processed.

The folder /home/pi is the project folder name. I’m sure, did not copied over any userdata from other devices.

To exclude errors from the played content.
Could you point me to a download source for short reference video files?
Does it make sense for you to switch over to the devel channel?

Why can’t you play the files locally from internal storage to rule out an issue?

I’m running these files from local storage without issues.
I also played these file in the loop without issues. These actions (play a single file, loop a file etc.) are called from local script via json rpc. No issues for days.

The issue happend when a playlist with two entries is processed:

  1. script is running the playlist with two entries
  2. at the end of the playlist processed first entry, the second entry from playlist is running
  3. script detects the end event via json rpc from the first played entry
  4. calls “goto index 0” to play the first entry again

As you can see from logs the sequence works for a lot of iterations, but not forever and results in an crash.

Could be a race condition.

Without seeing the script, it’s impossible to tell.

If this is for a commercial project, it’s best sent to