Vero 4K+: ‘Failed to copy the Backup Tar file’

My Vero 4K frequently fails to copy the Backup file. My Backup file is only around 6MB and I have plenty of space on the Vero. I started a thread before including logs but got virtually no answers.

I’m confused as to whether I should be setting the Backup location on my NAS or can I just use /home/osmc/Backups ?

Ran a Backup with Debug Logging and of course it worked ! Aaaah !

Anyway, here are the logs

You can use a location on the Vero but it won’t do you much good if you have to re-install OSMC as that will completely re-write the internal memory.

Ah yep, forgot about that situation. I presume you have to use

Is there a settings file I could edit through SSH to make it easier to type it in ?

Yes, it is


item <setting id="backup_location">...</setting>

1 Like


So I started looking at copying the Backup Tar file to my NAS but had issues using this format:-
that I think may have been due to using symbols in the password.

Instead, I used this guide to setup SMB and NFS to my NAS:- Mounting network shares with autofs (alternative to fstab)

After that I could now use Browse to set the Backup location to:-

Now I’m no longer getting any ‘Failed to copy the Backup Tar file’ messages

1 Like