Vero 4K+ First update to Kodi 18 (Leia) 480P OSMC UI and movies fail to play

Hi all,
I had been getting all the functionality I needed from Kodi 17 so held off updated, and I think my box rebooted and update was applied.
Now upon boot the UI is displayed at 720x480p and 1080p movies and all but one 4K movie will play.(so far haven’t tested enough as have family over and was trying to setup a movie for the kids.

I have a JVC DLA-X570 and Denon 4k receiver. No issues prior to update to latest but did skip updates in between so can’t say which update caused the issue per se.

Have Lock HDMI HPD set and tested with Force 422 colour subsampling

Log here should show boot right into 480p and then manually attempted to set to 1080p and reverting back to 480p

Going to try and force 1080 and play around with different movies to try and provide more info

Any help is appreciated. Thanks!

That could not have happened unless you agreed to the update, or did it manually.

We’ve seen odd problems with Denon’s in the past. The first thing I’d suggest trying is to connect the Vero directly to the TV and see if the problem continues. It that works, then we can try and work around what the Denon may be doing.

My kids may have done it, no worries on the update. Just wanted to clarify that I was on something very old and moved to the latest.

If this is the only option I can try it, Its a projector so its a giant pain to connect directly. Will see how that goes, thanks for the reply.

I was hoping that it would be easy to just connect to the projector to rule out the Denon. Others may have better ideas for you to try.

Thanks for the quick replies!

Turned out had an extra cable with easy access. Just connected direct now and same issue, another thing thats odd is that i cannot find the whitelist option noted in many of the other threads talking about resolution issues. :thinking:

Make sure you have expert turned on. But you normally would not need whitelists. Can you post a new log with it connected directly to the JVC?

Yeah just found that right before you replied. Tried adding it just for a test but you are right made no difference so removed the test ones I added

New log direct to JVC. Boot goes into 480p, manually try to change to 1080p goes to a screen that looks higher resolution but hard to be sure and flashes off and comes back on 480p. This is the same as what is was doing before going through the Denon

Could you try this experiment. Try resetting Kodi to default setting and see if the problem still happens. (Don’t worry, your library and settings wont be lost, it just a test to see if it’s an odd setting).

You need to SSH in to do this

systemctl stop mediacenter
mv .kodi .kodi.bak
systemctl start mediacenter

And see if you can now get 1080 working. If that works we can go from there.

1 Like

Lol yep glorious 1080p back on UI, so odd setting somewhere. Thank you!

Share a log again, and I’ll see if I can find the differences. You could try this and see what happens (after sharing the log)

systemctl stop mediacenter
rm -rf .kodi
mv .kodi.bak .kodi
rm .kodi/userdata/guisettings.xml
systemctl start mediacenter

Now your library and other stuff will be back, but the gui is to factory settings.

1 Like

Ok here is the clean log at 1080p/24

After your suggestion above I get 1080i/50. And all movies play at 1080i including 4k movies
Here is a log of that →

Well that is the prefered mode the JVC/Denon reports


After the reset of the guisettings.xml you have to reconfigure Adjust display refresh rate as start/stop

1 Like

Updated that and still not going to 1080p or 4K. Also 4k movies giving a sad face (BSD like screen)

I am ok to resetup from scratch without the backup unless you guys want to keep investigating as in without the backup I am getting 1080p/24 on boot.

Might be the easiest as something seems to be odd in between.
Do a fresh install, set gui to 1080p and enable Adjust Refresh Rate Start/Stop and you should be good to go

1 Like

Yeah cool thanks to you both. After I get that setup I will post back here when all is working.

Thanks for the quick help! Very much appreciated

Glad we were able to help. I haven’t had a chance yet, but out of curiosity I will look closer at you logs to see if I can spot what happened to cause this.

1 Like

awesome I would be curious, i am going to guess my fault for not being on top of updates and the big jump caused an issue.

The switch to a low res is a known issue with the change in guisettings from 17 to 18. Should just have been necessary to re-set the resolution to 1080p.

Let us know how you get on.

Sorry for the slow reply, had some usb/sd card media issues. After rebooting Vero 4K+ was stuck back in 1080i again. Did a clean load after sorting out media hardware issues. Loaded the June build and then did an OTA update to the latest.

All is working perfectly again. resolution switching is working perfect. Thanks again for the help your responsiveness is much appreciated!