Vero 4K+ freezes after a while

Hi, I have had a Vero 4K+ for about a year now and, for the most part it, has been great. However, every now and again, it locks up. This can happen while I’m navigating the UI, while playing a movie or while playing music.

A couple of things are almost guaranteed to make it freeze: scanning music files or calibrating the screen.

Sometimes when it locks up in the middle of a movie, green blocks appear randomly on the screen. If any sound is being played, the last few milliseconds (presumably what’s in a buffer somewhere) will repeat. It’s completely unresponsive to pings or SSH.

The Vero’s connected to a Panasonic LED TV via HDMI. Video & audio files are served from a NAS. I use NFS for the video mount. I’ve watched 4K UHD BluRay rips (direct from disc with no re-encoding) without issue, so I don’t think it’s network related.

For some reason, it became completely unstable after the August update. Swapping out the PSU for a Raspberry Pi Hub one seems to have reduced the frequency of lock-ups to the extent that I can watch a movie or two before it locks up.

I’ve attached some logs. I had enabled systemd journalling, but I’ve had to snip out a lot of it in order to keep the size of the log file down so that I could upload it.

I have also monitored CPU temperatures. They’re generally between 50C (idle) and 68C (displaying menus while also playing a 5.1 FLAC file). The temperature was in the mid 60s when it last crashed (at 14:45 as per the log), but this does not seem that remarkable.

As for attached USB devices, I normally only have the remote control dongle attached. I’ve tried removing it, but that didn’t make any difference.

Well not related to your problem, but you should never have the need to calibrate the screen

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off
1 Like

When was the freeze? Would just be easy to take logs from that time.
How does the freeze represent it self? Are SSH and Webcontrol still working?

Thanks for the advice. It was indeed an issue with overscan. I’ve turned it off, reset the calibration so that all the offsets are 0 and it seems fine now.

I’m afraid I don’t know exactly when it occurred. My guess of 14:45 was based on the timestamps of the kernel messages in the systemd journal log, but there are messages in the Kodi log file going right up to 14:49:37. Going by the fact that I started playing a track that was 4:03 long at 14:45:54 and it froze partway through that track, 14:49:37 could well have been when it froze. In fact, it has just frozen again 3:21 into the same track. I will post the new log. I was running a bash script that echoed the value of EPOCHREALTIME over a socket to a remote server, so I should get a more accurate idea of when the freeze occurred this time.

SSH and the web interface were both unresponsive and pings from the NAS did not get a response.
I was actually logged in and manually checking the /sys/class/therm/thermal_zone0/temp pseudo-file every few seconds up until the freeze occurred.

New logs, same symptoms as before.

Last recorded epoch time was 1640260614.095164, which translates to 11:56:54.095164

This is consistent with the picture freezing at 03:21 into the track that started playing at 11:53:33.339

There is very little recorded in the logs after the track started playing, other than some SMB and NFS messages and a Window Init() message 3 minutes into the track.

I was also recording the temperature, which had crept up from 59 degrees C to 65 degrees C from when I started playing the track to when it froze.

I will try a few things with the same track/different tracks and see whether there’s a consistent recipe for reproducing the issue.

Hello. Some monthes ago, I had a lot of freezes during or at the end of a movie, with green artefacts and then a hanging sound and no response at all, even with SSH. No one never got a real solution for me. I had to resinstall completely my Vero with Matrix in order to have decent views without freezes. Now it works, sure, but Matrix seems to be slower than Leia, specially on a Vero 4k+. It was not a CPU problem either.

@laurent.sailla It’s possible your device was overheating. With Kodi Matrix we introduced a 4.9 kernel with better thermal governing, and this could have solved your issue.

Perhaps, indeed. Or not. We don’t know. With HD videos, Netflix and so on, temperature can reach easily 75 to 80 °C, without any problems, even with Matrix. The Raspberry too can have high temperatures without hanging. I always forced performance governor on Raspberry pi too, and ofter overclocked it without the problems I met with the Vero. A recursive and cycling hanging is not a good thing. However, my Vero seems to be stable nowadays, and yes it certainly dues the new kernel. Temperature as gone down and is more often 65 degrees than 78 like in the past.

1 Like