Vero 4k Freezing when cleaning video library

I would recommend using a powered USB hub or you will likely at some point experience corruption of the drive.

Regardless this would still be a valid test to track down where the issue is coming from. You may also want to plug it into windows and run a chkdsk.

We are not looking to do file transfers, just get access to the terminal so i’m not sure where you think WinSCP comes in. The logs you grabbed look to be after the machine had been rebooted several times so any information about when it supposedly locked up during the file clean is gone. When it freezes if you can still establish a connection with SSH then you can type in…

grab-logs -A

…which should gather the logs and then return a url that you can post in this thread. This will hopefully show what is going on with the system prior to the freeze.

Shouldn’t this be abundantly clear somewhere, I’ve not seen anything about this issue?

And, Yes I do have a small amount of week sectors on the drive, doing a surface test at the moment!

In Reply to your quote that “with windows 10 I dont need to install any extra software”

I may need to repair my HDD .

Could someone tell me what Kodi files I need to save to retain the status of what films, tv shows I’ve watched?

I’ve got back up of the movie and tv show and music files, and can re-scrape the metadata if needed, and have extra artist info in separate folder, but not sure where the info of what I’ve have and haven’t watched is kept?

Hopefully I won’t need this, but just in case the HDD repair doesn’t go smoothly…

Regards Phil

The metadata is all kept in the Vero itself in ~/.kodi/userdata. You can replace the drive and retain everything as long as the new drive is using the exact same file path as the old drive. If you bring up the information screen on one of your videos and highlight the “refresh” you should see a file path for that item that i’m guessing is something like /media/something/movies/somevideo/somevideo.mkv so a new drive with the files named the same should only need the drive named the same so in the previous the drive would need to get named as “something” so it looks to be the same as the old one. Alternatively you could manually make a system mount to force this, or you could add a path substitution to an advancedsetting.xml to redirect to the new location.

The Vero 4K + implements the USB 2.0 specification. This means we can only output 500ma per port. This is touch and go for 2.5" disks.

We do try and make it as clear as possible that you really need a dedicated power supply or a powered hub if you plan to attach several peripherals or a hard disk.

Sam

Thanks Darwin,

I’ve reconnected the drive with a powered usb hub and copied the Kodi/user folder to PC. So fairly safe if it all goes wrong.

The disk repair option on Sentinel should preserve my good data, but Its unable to tell me what files are on the bad sectors as the drive is unmounted.

I’m assuming it would be ok to mount it, try and find the corrupt file, and then unmount it again.

Or will my Vero still thinks it’s the same drive if its mounted or not?

Just want to make sure…

Phil

I don’t think mounting the drive on another computer should have any effect on how it shows up in OSMC. I believe the auto mount in OSMC uses the drive name for the mount folder, and if the drive is not named then it uses a hardware id. Neither should get changed by simply mounting the drive on any system. Even if it was, fixing that issue should not be all that difficult.

Managed to repair my HDD Successfully, but still the same problem.

New logs taken as requested: https://paste.osmc.tv/lumutokoba

Phil

Your log has several errors like this:

2020-08-17 19:05:28.124 T:4064882688   ERROR: CCurlFile::Exists - Failed: Timeout was reached(28) for https://192-168-0-10.be1dc883f7814d5889c2d7f6afc1ca43.plex.direct:32400/video/:/transcode/universal/start.mkv

It looks like there is a problem with your plex configuration.

It did finish…

CleanDatabase: Cleaning videodatabase done. Operation took 22:07

It just took a long time because you have issues with your Plex setup. There is a bunch of this type of stuff…

2020-08-15 17:04:22.099 T:4064882688 ERROR: CCurlFile::Exists - Failed: Timeout was reached(28) for https://192-168-0-10.be1dc883f7814d5889c2d7f6afc1ca43.plex.direct:32400/library/parts/7734/1585175024/file.mkv

The cleaning time is related to how many entries it can’t access as it has to wait for the access attempt to timeout which dramatically slows things down.

1 Like

Thanks for both replies.

Pc mouse decided to pack up this evening as well this evening, Replying on my phone…

I’ve not used or opened Plex for months, server is not running on pc either, but will remove programme from vero. And check again.

Also lots of stuff on the log about the weather app! How do I totally disable it, didn’t like it much, thought I’d disabled program already?

Or would I be better off just reloading OSMC and starting from fresh?

Regards Phil

You could remove the current database and build a new one. I did notice the weather app errors, but I didn’t look that close at them.

It may just be easier to start fresh with a new OSMC installation.

I assume the database entries were from you running PKC at some point and that add-on does some tweaks to Kodi that may not all get reversed by just uninstalling the add-on. I’m pretty sure the dev behind it recommends a clean install if you decide to stop using it.

I’ve had this problem for years. The only suggestion has been to recreate the database, fed up with doing that and just remove as I go now. I’m connected to a Synology diskstation. It just started happening a few years ago, before that it worked perfectly.

Thanks for everyone’s help, have reinstalled OSMC and reloaded my user data, all seems to be working fine.

Sorry it took so long, had blue screen of death on my pc, so my spare time was taken up with sorting that out first.

Phil

However, after the cleanup those entries should be gone and you never would have to experience that slowness again, right?. Otherwise why would there be a cleanup, if it doesn’t cleanup files that are not reachable/accessible?

Also, maybe there’s a way to tweak the timeout to a lower value, let’s say 2s.

I changed my network at home (IP addresses) which shouldn’t matter since I access my media files via a share that is mounted to a local filesystem. (Thus Kodi only sees the /mnt/bla and not any ip addresses or hostnames.)
Yet, I had to wait 37h for the cleanup to finish. This is ridiculous and no, I will no delete my database, because it took me a while to fix all the scraping errors.

It removes library entries for media that no longer exists. It does not seem to remove old source paths from the db that no longer exist. To get rid of those you have to edit the db manually I think (that is how I have gotten rid of them in the past).

Not that i’m aware of.

That is insane. Clean library on my video db takes seconds. I would think if you turn on debug logging before a clean and take a look at Kodi’s log you should see what is going on.

The database is not entirely 3NF, so a guide for doing so would be great.

I will certainly do that when I run into this problem again. I haven’t cleaned the db since then, so I don’t know, if the problem still exists.

The part I don’t understand is why there would be any ip addresses in the database at all. As mentioned before, I use a local mount point (since I mount via fstab and not Kodi).