Vero 4k+ gives an embuary info error


Lately I’m having a lot of embuary info errors. The errors start a few hours after rebooting and keep coming until de vero crashes and reboots.
I tried to make a log, but could not reproduce the error while the logging was running. After a while the errors started again and altough the logging was not running I still found the error in the kodi.log
I used the log uploader and got URL: zolufidari. I hope this is correct and the upload has the error in it.

I can see errors, such as

2023-02-16 21:56:32.042 T:4018    ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'AttributeError'>
                                                   Error Contents: 'datetime.timedelta' object has no attribute 'timestamp'
                                                   Traceback (most recent call last):
                                                     File "/home/osmc/.kodi/addons/", line 7, in <module>
                                                       from resources.lib.helper import *
                                                     File "/home/osmc/.kodi/addons/", line 15, in <module>
                                                       import arrow
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/", line 2, in <module>
                                                       from .api import get, now, utcnow
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/", line 12, in <module>
                                                       from arrow.arrow import TZ_EXPR, Arrow
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/", line 34, in <module>
                                                       from arrow import formatter, locales, parser, util
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/", line 26, in <module>
                                                       from arrow.util import next_weekday, normalize_timestamp
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/", line 6, in <module>
                                                       from arrow.constants import (
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/", line 16, in <module>
                                                       _MAX_TIMESTAMP = datetime.max.timestamp()
                                                   AttributeError: 'datetime.timedelta' object has no attribute 'timestamp'
                                                   -->End of Python script error report<--

But I’m not sure what the solution is. Perhaps you could contact the developer of these add-ons / skin and see if they have some advice.


Hi Sam,

following your advice, I looked on Kodi and found similar reports:
This one points to

this one concludes it is a python error and points to a fix

Any chance of implementing this or will this be solved in a python update?


1 Like

Thanks for checking this out.

We follow Debian’s version of Python, so this will need fixing upstream.