Vero 4K+ hangs and reboots after update

Dear colleagues,

First of all, wanted to thank you for super-great OSMC software which is running on my media devices for my and other families. It’s really hassle free and well maintained. Thank you for your great work!

Now to the issue. Context:

  • I have Vero 4K+, which was running happily on some old OSMC from 2019. There was no issues at all: 4K, HDR, rips for 80Gbs and all. Absolutely happy.
  • Then I’ve decided to join effort in testing Moonlight for Vero 4K+ and for that needed to update OSMC to a higher version.
  • Update went fine from CLI. The only exception was Kodi, which got higher major version, so I had really hard times to bring at least part of plugins I was using back to life. Not an issue of OSMC though.

The problem:

  • After update, I’ve started randomly receiving “sad smile” as well as framebuffer corruption (half screen is, let’s say blue color, which persists Kodi restart, or whole screen is green, till device restart, persists Kodi restart, etc.).
  • Issue can occur while idle, at night, while playing videos, etc. I haven’t got pattern it occurs in. But now I can barely view a 2h movie without this kid of a bug.
  • Issue started exactly after update. Means no issues at all before (device was constantly used, that couldn’t be missed) and permanent issues after. No hardware (power, network) or other conditions were changed. I haven’t event touched device during update - it was and is controlled over SSH.
  • Besides this issue - device operates normally - there are no glitches or other unexpected behaviour when it works normally.

What have been tried:

  • I was thinking that device is getting overheated, as issue seems to occur more frequently during video playback, however moving device to other location phisically didn’t change anything. CPU temp has dropped 85C → 67C on this move. 67C seems normal temperature to me under load. Device is warm on touch.
  • Looked into kernel logs to find any clue on what could be wrong: everything seems normal. On kodi restart - it shows display initialization lines related to HDMI. Nothing inbetween those lines.
  • Applied most recent update, the following after previous one, i.e. updated to 2023-01. However after booting into Kodi after 5-10 seconds I’ve got sad smile.

Not sure what else I can do from here as well as not sure if I’m alone with this kind of a problem - haven’t found similar topics.

Here are the logs from device:

I hope you can help me, because now using Vero 4K+ is a pain - I would prefer not to rollback to an older release due to a Moonlight testing.

Thank you.

We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate>Always

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Tried that. Unfortunately it didn’t help.

Also if that would be the case, it wouldn’t crash during native 4K playback. And it did.

I would suggest to test to see if with stock settings (and no extra add-ons) if playing back a local file still exhibits this issue.

How to test with default settings

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Thank you for suggestion @darwindesign. I’ve ran that and Vero wasn’t rebooting, so I’ve started to troubleshoot possible plugins that could have caused it.

It seems that cause of this was a plugin. However there was an update to it and Vero stopped rebooting after. I even put Vero back to where it was before the upgrade, and where it’s hotter.

This is still surprises me how 1 plugin can bring whole Kodi down, but it’s definitely not related to OSMC and Vero in such a case. Kodi 19 is disaster, to be honest.

Will keep monitoring and will update the topic should the issue return.

Thank you for your help!

(mod edit: I removed the name of the add-on because it violates our piracy policy)

1 Like

Unfortunately this is the case, but Kodi plans to have add-on isolation in the longer term and sandboxing which will hopefully improve things