Vero 4k+ hogs hdmi, disables CEC of all other hdmi devices

I bought a Vero 4k+ and technically it works, it even turns on TV/AVR when started and goes to sleep when I turn off TV. But as long as it is connected to my receiver it somehow disables the hdmi auto TV power on and off of all other sources (Nintendo switch, chrome cast, raspberry pi 3 running kodi). i.e. When I power on a device the receiver and TV turns on automatically and changes to the device that was turned on,and when I turn off the TV, the device also turns off. But with Vero connected this no longer works for any device but the Vero itself. I have to turn on TV manually now and when powering off I need to power off all three devices (TV, receiver and source)
Ive tried to change the CEC settings in Vero, power Vero down to standby or shut down completely. Even pulled the power of the Vero, but in order to make the other devices work again I must disconnect the hdmi cable.
Everything works, just not together with Vero. Why is this? Is it a design flaw in Vero?

I have not seen this. The first thing you should try would be to try a different HDMI cable.

I’d suggest powering everything off at the mains for a few minutes.
If the issue persists, some logs should help us determine what the issue is

It would also help to know the make and model of your TV and AVR.


What TV and receiver do you have?

Yes, I was using the same HDMI cable that I used for my old Kodi RPi3, and there it worked fine.
But I have now replaced it to the HDMI cable that was supplied with Vero4k+ and it is the same behavior.
Since the old HDMI cable was already detached (so that the other sources would work) , I attached the new one and tried power on the Nintendo switch, but I get the same symptom, the TV and AVR doesn’t turn on.

My AVR is an Pioneer VSX-934 and TV is an LG OLED55CX6LA.
The Vero4k+ is connected to the AVR as are all the other devices.

A lot of people have CEC issues with LGs.
Not to say that it’s an LG only issue, because other brands have had similar issues as well, just not as much.
Maybe our community has a higher representation of LG OLEDs than most.
That being said, I had mine all dialed in with no CEC errors.
Since the latest kernel, it’s been a nightmare.
If I try to use a different input, on my TV or my AVR, after about a minute or less everything switches back over to the Vero.
So if my children want to play the Switch or something I have to shut the power down on the Vero.
Then when they are done I can power the Vero back up, but a new issue arises, when I play a video and the Vero switches the resolution, I lose the Vero and my system changes input over to the Switch (which is not even on anymore).
So I have to get my remote and switch everything back to the Vero to watch the video and it stays put.
It’s pretty annoying.
Maybe I’ll figure it out.
But I hate CEC with a passion.
Even if you disable it on all your devices, it still does wacky stuff.
I might just invest in one of those HDMI cables or adapters that strips it physically.
If I figure out a new solution I’ll post it here.
Follow this link to see my old solution: No Hdmi ARC on AV receiver when V4K is hooked - #24 by Kontrarian
Some people found that it worked for them.

Hi all, I am having a similar issue with my Vero 4K+
I have a Samsung TV (UE49MU7000) with a Samsung HW-Q700A Soundbar. The Soundbar’s ARC HDMI is plugged into the TV’s ARC HDMI port. I have my satellite receiver plugged into the TV direct (HDMI 3).

If I leave it like this then (no Vero 4K+ in the mix) then ARC works fine and all is a happy place. As soon as I plug in the VERO 4K+ into the Soundbar all hell breaks loose with ARC. I have the Vero 4k+ plugged into my Soundbar’s HDMI in port to give me Atmos (as the TV can’t passthrough the Atmos). If I leave the Vero 4K+ in standby at the ned of a session then things behave just fine (with regards to ARC) but … When I am finished with the Vero for a while I like to unplug it after a shutdown (as I don’t use it all the time). If I unlplug it (after shutting down of course) then almost straight away the TV loses its ARC connection to the soundbar and only the TV speakers will work. This is with the VERO physically off. It also behaves the same if I do a shutdown but don’t unplug it from the power. The only way I can get the ARC working again is to unplug the HDMI lead from the (fully OFF) Vero 4K+, turn the TV and Soundbar off and then back on again.

I have tried disabling HDMI-CEC on the Vero 4K+ and it does not help.

As I am getting up to turn off and unplug the Vero 4K+ (when I 'm finished with it) it is not the end of the world but is is flaming annoying if I shut it down and forget to unplug. If I forget to get up and unplug the HDMI lead (while unplugging the power adaptor) from the Vero 4K+ and go to work then other members of the family will have no chance to fix it (as they won’t remember that the HDMI needs to be unplugged). It’s like the Soundbar/TV still see the Vero 4K+ even when it is unplugged.

I then tried to get an HDMI switch (thinking it was an issue with some devices plugged into the TV and Some into the Soundbar) and plug both the Satellite box and Vero 4K+ into the switch and the HDMI of the switch into the HDMI-in of the sounbar and was even more freaky. When the vero was unplugged it still seemed to be getting power from the HDMI lead - i.e. when physically unplugged from the mains the red light stayed on!! The HDMI switch was somehow passing juice to the vero (the HDMI switch was switched to the satellite box) so I wonder if the HDMI switch was somehow giving power to the Vero 4K+ via the HDMI lead. Is that even possible??? Anyway - I sent the HDMI switch back as I worried that it might cause damage and reverted to plan A with the Vero 4K+ plugged into the Soundbar HDMI-in and the Satellite box connected to the TV.

The HDMI switch issues did half make me wonder if the whole HDMI ARC issue might be due to power getting to the Vero 4k+ via the Soundbar or something bizzare like that??? Peace was restored (as long as I remember to unplug the HDMI of the Vero 4K+ when I’m not using it).

This all seems very odd to me (not being that technically minded when it comes to HDMI CEC etc.

Without any logs I don’t really have any ideas

If the Vero 4K+ is physically off though I don’t understand how a log can help. It can’t be logging anything if it has no power.

If you give me the steps you think would help (re: gathering logs) then I will definately supply some. Just tell me what logs and at what stages you need and I will get them over :slight_smile:

CEC communication happens over a single line in the HDMI cable. Some devices, and I believe the Vero’s are included, have a protection circuit wired such that it balances the voltage on that line between the devices mainboard voltage and ground. If you remove the devices power then you end up with just ground on that line and that can cause other connected devices to no longer be able to communicate over CEC as it grounds out their communication as well. I think the oldest Raspberry Pi’s were wired like this as well. I think the Pi’s moved over to a design were they floated the communication between the power and ground supplied in the HDMI cable which mitigated these issues.

Unfortunately this means that if you want to cut power from your device like this and not have problems you have to physically disconnect pin 13 on the HDMI cable connecting to your player. They sell “CEC less adapters” to do this. You can also find information online about physically modifying a cable to effect this change as well.

1 Like

Hi darwindesign, Thanks so much for that - I thought I was going mad. I’m not sure providing logs to Sam would help in any way in that case. Would/could that also explain why the HDMI switch I tried to use was somehow powering up the Vero 4K+??

Hi Sam, Are you aware of what @darwindesign is explaining. If so it would be really helpful to have something in the troubleshooting Wiki to explain this for future new users so that they know of this issue. It has caused me no end of hassle and stress to be honest. I have reset my TV 3 times (and that is no mean feat) and also reset the Soundbar twice (and that is even more of a pain with Samsung Smartthings app).

ps the switch in question was amazon item B0928XP25L

I think I will just unplug the HDMI when I am finished and pop a sticker on the power supply of the Vero that says “Remember to unplug the HDMI lead”.

There is power and ground supplied through the HDMI cables, but it is very minimal current capacity. It is enough for some powered splitters and optical converters but well outside of what could actually power a Vero or any other media player. Why supplying power over HDMI to an unplugged Vero would make its status light glow I could only speculate. I don’t envision how it could possibly cause any harm though.

1 Like

when I’m feeling brave I might carefully bend back the pin 13 on the HDMI lead into the Vero 4K+ BUT… I’m not doing anything to pin 13 on Friday 13th - that is asking for trouble :laughing: :laughing:

Get one of these, to disable pin 13 -

Yes. Sorry – I didn’t realise you had issues when the device is off.
This is expected. CEC cannot work when the device is not powered.

I would say it is okay for this to happen and I totally accept it’s a limitation due to the wiring of the internals of the Vero 4K hardware. It would be really really helpful if people could refer to the Wiki or troubleshooting for the Vero 4K+ and find that information. Non technical end users like myself might otherwise get very frustrated and potentially waste days reconfiguring their equipment thinking the TV or other equipment is at fault or the HDMI cables are faulty etc. I also spent over an hour on chat with Samsung support, purchased an HDMI switch to help troubleshoot the problem and so forth.

The average non technical end user would not realise that a device that is fully powered off could affect other devices in the home theatre setup as it makes no logical sense unless you understand about grounding and HDMI pins and daisy chaining etc.

Darwindesign explained it well for me (the layman) and after understanding that I had no problem and knew what limitations I had to work alongside.


1 Like

Thank you @darwindesign for the perfect explanation of why this is. As I see it this is a hardware bug and I hope for it to be fixed in the next version or revision of the hardware.
I always powered off my old Osmc (RPi3) and it worked seamlessly with CEC in my system. The only reason I bought Vero was to not have to bother with Widevine support. But it is now clear to me that I will return the Vero and find a fix for my old system.

Thank you all

I think it is more of a limitation than a bug. I came across this information with a general web search as there is lots of posts out there of lots of different devices behaving similar. I can see how this could be a deal breaker for some depending on the situation. In my own setup I just pushed up pin 13 on the cable going into my Vero to disable CEC and bought a FLIRC USB receiver to use with my Harmony universal remote. With this setup I have more function than with CEC, more buttons to play with, and it doesn’t care if I pull the power or not.