Vero 4k+ & IR+wireless network

I did a clean install of the Vero 4k+ (2018-12.1). The only changes were:

  • disabled wired network.
  • Enabled wireless 5g
  • Added rc6-mce-lircd.conf profile (via the GUI)
  • SSH into vero.
  • run irw
  • A single push of the down arrow caused it to go into auto-repeat until I cancelled irw (CTRL-C).

Next, I will try an older version of s/w.

I just tried this with 2018.07-1 and the result was the same. This is consistent with your statement that the driver hasn’t been touched in a while.

That begs the question: Am I the only one that has this problem? I would guess that most people would be using the rf OSMC remote, but I would expect somebody else to have my configuration.

Are you able to try with the Vero in another room quickly?


What would you like me to try? A different s/w version? I have tried, with the 2018.12-1 software on both the vero 4k and the three vero 4k+ and they all exhibit this problem.

I am guessing from your question that you cannot duplicate the problem.

I meant a physical relocation.
Can’t repro here unfortunately


Well, I do have the same problem with IR being slower than what would be ideal. The extender improves reception but makes no difference in terms of lag. Mine is connected to the router with a utp cable though, so wifi is probably off. I use a Sony universal IR remote, which sends commands immediately, and works perfectly with both a pi 2B and a pi zero w with both a tsop on the gpio and OSMC on them (all using the xbox 360 profile).

It feels like my 4K+ needs 300-400 msecs before a new IR command can be accepted, but if I start pushing buttons in rapid succession, it will start executing commands (or most of them) quickly. I tried disabling the repeat filter, but that results in commands being executed multiple times with each key press, so I changed that back. It’s workable, but scrolling through lists and skipping back/ahead while playing video could be better.

I never had an IR command ‘hanging’ on repeat though.

I set up a portable system (small TV with 720p resolution) with a vero 4k+. Starting with a fresh install of 2018.12-1:

  • Set language to English(US)
  • Set region to America-New York
  • Said NO to newsletter
  • Disabled wired network
  • Enabled wireless 5G network
  • Added rc6-mce-lircd.conf to remotes
  • SSH into vero and run irw.

I moved this around to various rooms and even turned the TV off in case the display was affecting the IR receiver. All it takes is one or two button presses to get it stuck into auto-repeat. Killing irw will stop the auto-repeat.

I then switched to 2.4G wireless and I could NOT reproduce the problem. The IR receiver would miss button presses, but it did not go into auto-repeat.

That’s annoying. I’ve seen repeats before when using an LIRC profile from the web or if there was high CPU usage.

I’ll see if I can reproduce with some load.


Well, I guess that I wouldn’t spend too much time on it. During this exercise, I have learned that the direct IR (built-in or extension) is not very sensitive compared to the USB dongles that I have. I think that I will pick up a few more USB dongles and go that route.

Thanks for all of your help.