Vero 4k+ & IR+wireless network

I have discovered an incompatibility between the wireless network and the hardware IR receiver (either built-in or plug-in). There is NO issue with the following configurations:

  1. Wireless turned off. This is not quite true. I still have some missed key presses.
  2. OSMC wireless remote.
  3. USB IR remote receiver.

However, if I use the built-in or plug-in IR receiver with wireless turned on, the remote receiver skips inputs (doesn’t receive all key presses) or will get stuck in repeat mode. That is, I press a button and it just repeats forever. I have been able to release it a few times by:

  1. Pressing a different key. This has worked a few times, but it is more likely to just grab that key and repeat it.
  2. Log onto SSH. This freed it up once, but it might have been coincidence.

This is repeatable on all 3 of my 4k+ units (one purchased in August, the other two in January). I am running release 2018.12-1.

This is less of a problem original Vero 4k (non-plus) and Raspberries, although I still have missed key presses.

I notice that the problem happens when the unit is accessing the network (to update libraries, for example) at the same time that I press a button.

I have uploaded my logs to

I use a DirecTV RC65 remote with a custom built config file. The file is a raw codes file.

I had a problem with the original vero 4k a while back where it would not respond to the GPIO IR receiver. It was fixed in a later version. The USB IR receivers are not affected by this “bug.”


The USB receiver is RF; so doesn’t require line of sight or use infrared.
IR can be disrupted by high CPU load. Can you check the system load when this happens?


For what it is worth, when I run irw (no options) I see the repeats coming from linux-input-layer. When I run “irw /var/run/lirc/lircd-lirc0” I do not see the repeats.

I am not talking about the OSMC rf remote. That works too, but I use an IR USB dongle.

If you’re seeing repeats with a USB dongle, it’s unlikely to be OSMC related or a problem with the built-in receiver.

If you are using the USB receiver, I recommend running sudo rmmod meson-ir to disable the internal receiver and prevent duplicate presses. If this works, you can blacklist this module.

Here are my CPU loads while it is happening. I can force the issue by running irw on a SSH session. Then press a key a couple of times. Since this is sending output over the network, it causes the key to “stick”. That is, constant repeat. If I cancel the irw, the repeating stops.

CPU0: 0-41%, CPU1: 1-23%, CPU2:0-16%, CPU3: 0-2%, CPU-KODI: 14-30%.

I believe that you are misunderstanding my problem. When using a USB receiver (either the OSMC rf remote or my IR USB receiver) I DO NOT have a problem. If I use the built-in IR receiver or the IR extender IR receiver, is when I have the problem.

I only recently tried using the GPIO receiver on my Pis and I notice that the problem happens with them as well.

Ok, thanks for clarifying.
I would suggest re-recording your LIRC profile with the internal receiver.

OK. I can try that. The last time that I had an IR problem, you were not able to duplicate. What IR remotes do you test with? I have a pile of remotes and I may have one that you use.

Some cheap and cheerful no name NEC ones and a 360 Media Remote are the nearest accessible ones.

I can’t get irrecord to work. It gets past the first phase at identifying the type of remote, but fails trying to learn a key. I tried 3 different remotes. I tried the suggested -f option, but that didn’t help.

I have a RC6-mce remote (rc6-mce-lircd.conf) that exhibits the same problem.

I have been using my direcTV RC65 config files for years, mostly with a USB (IR) dongle. I only have had issues using GPIO IR receiver (assuming that is how your built-in receiver works).

Something odd there then if you cannot record a profile.

I haven’t touched the meson-ir driver for some time as it’s relatively stable. If this is also happening on a Pi (GPIO uses a different driver); then something else might be at play.

Can you try record the profile in another room?

I tried the same experiments on a Pi 3B+. The symptoms are not the same.
The GPIO input misses button presses occasionally. It will not reliably go into repeat mode if you hold a button down. I was able to successfully create a test conf file using irrecord. The file I created was a simple file with 5 buttons. I compared the profile to my stock one and it is slightly different, albeit the patterns of ones and zeros are the same.

I copied the file that I created on the Pi to the vero4k+. The same problem occurs, but it takes a little longer to get it to “button stuck” mode.

You say that you haven’t touched the driver in a while. I am not saying that this is a new problem. I only recently (on this version software) switched to GPIO IR. I don’t have enough of the IR USB dongles to go around and I thought that using GPIO would be simpler.

Ok, I will look at if it’s possible to improve the built in IR performance.

Maybe we can both test with an RC6 remote (MCE)?

Any progress?

Sam is pretty quick with fixes, but give him a little more than a day! He’s busy working to the upcoming 18.1 release.

I’m able to control Vero with the Xbox 360 media remote.
It’s not as responsive as I’d like, but it is working.

This is while there is traffic over WiFi? I can easily reproduce this problem by SSHing into vero and running irw. That way, I am guarantied to have traffic coincident (more or less) with the IR input.

I did not test over WiFi.

So to reproduce:

  • I connect to WiFi (2.4G or 5G?)
  • I use which remote profile?

Once I can repro, I can certainly advise / look in to resolving this.



I have tried both 2.4G and 5G and it presents with either.
Profile is rc6-mce-lircd.conf

SSH into vero and run irw. This will guaranty network traffic while receiving IR buttons. Press the up arrow or down arrow a couple of time in quick succession. It ends up getting stuck in auto repeat. If I cancel irw, it will stop.