Vero 4K+ isn't working

I tried to use my `Vero today and it wouldn’t turn on. I unplugged the psu and re-plugged it. I then got a screen saying “please standby” then a blue screen with the osmic logo, then nothing. I’ve removed everything connected to it, usb, ir extender, lan cable with no difference. I left it off for 30 minutes and tried again, same result.
I only got it a few weeks ago and used it for a couple of hours, its been on standby for a couple of weeks.
I’ve read a few posts describing something similar pointing to a suspect psu, so I tried plugging a usb a- usb a into a 5v 2.5A psu and into the usb on the Vero, nothing happened, although I can see the red light behind the optical connection come on.
Any ideas what might be the problem ?


If you are seeing the OSMC logo come up, then the system is booting as expected. But Kodi may not be starting or it may be starting but sending a signal your display doesn’t support.

The quickest way to solve things is probably to reinstall OSMC. See Reinstalling OSMC - Vero 4K - OSMC.

I did as suggested , OSMC successfully re-installed. After installation the Vero rebooted, some text came up top left of screen, then the OSMC logo then nothing.

OK – that would suggest to me that your TV doesn’t like the signal Kodi is sending.

Do you have another TV you can test on temporarily?
What’s the make and model of the TV?

Fortunately this pretty much rules out a hardware issue.

My tv is an LG OLED55CX , I have another LG OLED55B1 I can try it on. It was working fine on the same TV last time I used it, nothing has changed, same TV, HGMI cable etc

As I said I’d only used the Vero briefly after I received it, I can’t remember but shouldn’t the cross on the front of the Vero be blue when its on ? It isn’t illuminated at all now.

No – the blue light was removed in the 4K+ model, as it annoyed some users.

Red light should show up for 1-2 secs during boot, then turn off.

Thanks for that, it worked on my B1, same HDMi cable, very strange. One thing, I was testing it with a 2160p video file, while I was fast forwarding a blue screen with a sad face came up, the system then rebooted. I couldn’t get this to happen again so I’m not that concerned.
Thanks for your help !

Go to Settings → Display and enable ‘422 output’
This helps with some LG TVs.


1 Like