Vero 4K+ Issues After Update Kodi 19.3

Hello guys,
I hope you’re all going well.

Having tried the Kodi 19.0 update a while ago I was experiencing a few bugs and so I had decried to roll back the system using a backup. After waiting sometime, I decided to try the 19.3 update a couple of days ago. However, I’m still running into a list of issues that never occurred prior to the update.


  • Videos are slow to start including when using the up next OSD
  • Scanner freezes when updating/scanning
  • Watched status not updating in library, (either by watching or marking as watched)
  • Unable to restore interface from backup
  • Devices freezes (especially if video left on paused for some time)
  • Start-up error (warning free disk space remaining is only 0MB)

What do you guys think; should I just roll back using a backup or should I try to resolve them?

sorry apart from the logs I wasn’t really too sure what info I should includ.

This is basically your primary issue that also explains many of your other issues.

/dev/vero-nand/root   14G   14G     0 100% /

So you would need to find out what takes up all the space on your filesystem and clean it out. While it also could mean you have an incomplete upgrade which might be best way out is a complete reinstall.

Suggest steps:

  1. Login via SSH (see below)
  2. Delete all Thumbnails (as they will be recreated anyway) with command rm -R .kodi/userdata/Thumbnails/*
  3. After that check the free space with df -h / I guess that should be enough for a clean upgrade but maybe report back here
  4. If you need more space you can install ncdu sudo apt install ncdu which you then can use with ncdu -x / to see what else takes much space
  5. you also might have to remove the current databases to have them recreated from the old (v18) ones. for that best to show the output of ls -lah .kodi/userdata/Database/

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Hi fzinken,
Wow thank you for the super-fast post! Well, that was an easy one ahah. :slight_smile: Apologies, I’m not the greatest at reading logs.

What I actuality might do is reinstall & reformat using a tar backup and get everything working perfectly the way it was before. Then figure out what’s eating up all the space after which I’ll try again.

Quick question, when I’m ready to try upgrading again, will I have to will I have to remove and rebuild the database. Does this mean I’ll lose everything like watched/history ratings ect?

Thanks again for your ideas! :slight_smile:

No you don’t need to remove anything. Normally during an upgrade of a major Kodi version (e.g. 18 to 19) the database will be migrated. As part of that process the a new database is generated and the old one is retained. So I was just referring to the point if there was a space issue during the migration then you could delete the newer (Kodi 19) database as it would then restart the migration.

But if you restart from a tar backup and then check that you have enough space available might be the safer way.

So I’m having a little bit of difficulty restoring the system using a tar backup but I’m not too sure on what exactly is going on.

After reimaging the system using the “OSMC Installer.exe” (using image release 2020.11-1, as I believe that was the version I was running when I made the backup, before I upgraded to K-19.3) the vero4k+ works fine with the unconfigured stock image. Running osmc@osmc:~$ df -h /

Filesystem           Size  Used Avail Use% Mounted on
/dev/vero-nand/root   14G  1.2G   12G  10% /

After copying the home & ect tar backups onto a usb, I then run the commands

sudo systemctl stop mediacenter
cd / 
sudo tar -xvzf /media/restore/home_backup_110222.tgz 
sudo tar -xvzf /media/restore/tar_ect_backup_100222.tgz

After which the system is stuck in an infinite blue sad face splash screen loop. Am I missing something or could the tar backup file size be too large?
This is after restoring from the tar backup

df -h /
Filesystem           Size  Used Avail Use% Mounted on
/dev/vero-nand/root   14G   12G  2.0G  85% /

These are the current logs

As always thank you very much for all your inputs guys, I’d be lost without it. :slight_smile:

Kodi is segfaulting which is not good.

Feb 19 11:22:46 osmc mediacenter[2513]: /usr/bin/mediacenter: line 212: 2632 Segmentation fault

Are you sure you had the right version of the backup?
Try to remove the Kodi Folder to see if it comes up after that then we at least know where to search.

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Hi fzinken
Thanks for your reply

Just quickly, you wouldn’t happen to know where I could find in the files of the tar home backup, what version I was running when I made the backup, would you?

I’ll have to look and go through your steps once I’m back home. So my apologies for the delayed response.


Well you could check .kodi/temp/kodi.log that would tell you the Kodi version you were running. Also always interesting to check the databases in .kodi/userdata/Database/

Ok so, it looks like I installed the correct image. .kodi/temp/kodi.log in the home tar backup shows

Starting Kodi (18.9). Platform: Linux ARM (Thumb) 32-bit
Using Release Kodi x32 build (version for Vero)
Kodi compiled 2020-11-27 by GCC 8.3.0 for Linux ARM (Thumb) 32-bit version 4.19.152 (267160)
Running on Open Source Media Center 2020.11-1, kernel: Linux ARM 32-bit version 3.14.29-160-osmc

And the version installed; `grep VERSION_ID /etc/os-release` VERSION_ID="2020.11-1"

Running the other two commands didn’t output anything as with the last one rm -r ~/kodi.bk2

So after doing

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

Kodi didn’t started on screen?

Nope, the sad face just kept looping

Then it must have been something you restored from etc

Either try once more with a clean install and first just restore the home backup and not the etc.
Or try to enable debug logging to see if that tells more (unlikely with the segfault). To do that do:

sudo systemctl stop mediacenter


<?xml version="1.0" encoding="utf-8"?>

to .kodi/userdata/advancedsettings.xml
sudo systemctl stop mediacenter
Afterwards upload logs again.

Ok so that’s interesting
Restoration using the home.tar worked flawlessly with the GUI working just as it all was before.

And then once I restore the ect.tar that’s when the system crashes and ends up in the sad face loop.
Could It be that I didn’t first set up autofs prior to restoring the ect.tar or could it even be that I used a SD card to make the ect.tar backup and am restoring using a USB? Any advice on the best foot forward?

These are the logs from after restoring the ect.tar with debugging enabled;

The logs don’t show anything other than the segmentation fault.

That shouldn’t make a difference as long as you restore to the right folder.
Generally I don’t think you would have muhc in etc to restore anyhow other than autofs.

My suggestion:

  1. Clean install
  2. Install autofs packages
  3. Install mc
  4. Restore just the absolute needed files from you etc backup (like the customized autofs file) and for that I recommend to use mc as you can open the tar in one tab and have your etc folder in the other (need to run sudo mc to have write permission.
  5. Reboot and check that your folders are mounted correctly
  6. Restore your home folder
  7. Reboot and hope all works

Hey fzinken
Sorry for the raido slience, we just returned from a week away.

Restored only the “home tar” Set everything up and its all working perfectly now.

It seems that some issues were created thanks to the thumbnails folder eating up all the space. So I might have to start thinking of a soulation either using path substitution or something.

On a side note, before I try updating again from Kodi 18 to 19, do you know if there is a check list/instructions of things to fix after updating to 19 from 18 that a user can do?

Many thanks for all your help in getting my Vero up and running again!

Well there is no such list as normally everything should just work (at least on my OSMC devices that was the case).
The most likely issue you might run into is addons that are not anymore supported (they will be disabled).

Unless you have an exceptionally large library and also overrode the default size of the thumbnails it is unlikely that you would actually need to go this route. Likely what you have is just old thumbs that Kodi never cleaned up that are taking up space but it will never access. It is normally more prudent to just delete the thumbnail folder entirely and just let it rebuild. If you have concerns about old entries no longer having links to their original artwork you can do a Kodi library export which will pull all the existing art from the thumbnail folder.

Alternatively, use prune feature occasionally to remove stale thumbs…

I’ll have to look further into if some of my most used addons have any workarounds or not, especially the UI ones. But I think I might just stay on 18 for a while haha.

Thanks again for all your help!

Mmmm reasonably large, the thumbnails folder was around 9gb.
I’ll definitely be making thumbnail maintenance a semi regular thing.

Thanks ActionA I did come across this one, found it a little tricky. I did however end up finding a good youtube video on the subject.