Vero 4K+ messes with ARC

@pinn73, I have an LG C8 OLED with the latest firmware and I’m not experiencing any ARC issues.
I had issues at one point when I first got my Vero but found that if I set the Vero to send a power off to the TV when it’s screensaver kicks in I know longer have any CEC/ARC issues.
My Vero goes into my soundbar, not directly to the TV.
So if I finish watching something on the Vero, after a minute of idle (that’s what I set it to, it shuts down the sound bar and TV.
If I press any button on the remote, the Vero wakes up my soundbar and TV.
After it has shut down, if I turn on the TV with the TV remote (let’s say to watch Netflix or something), the soundbar wakes up and with a little delay the Vero does as well.
Sometimes if I turn the TV on and switch to a different HDMI or go to an app, when the Vero wakes up it switches my TV to it’s HDMI, which is actually the soundbars HDMI plugged into HDMI1 (ARC).
No big deal, switch the HDMI or launch the app again and everything works.
I’ve learned to just turn on my TV and wait for the Vero to wake up and display it’s home menu before I switch HDMI inputs or launch an app.
Not sure if any of that helps you, but maybe it will give you an idea of things to try.
CEC and ARC can be pretty finicky and sometimes just a complete power cylcle of everything is the only fix.

Thanks for the input but this unfortunately wouldn’t work for me as I need the device to be on 24/7.

Yes.

@pinn73: Have you checked that the AVR is just muted?
My Sony AVR is doing this starting AVR and TV with a Vero (CEC deactivated) connected. As far as I understood this is some confusing protection feature if one side of the ARC/eARC is not up fast enough to prevent speaker damage.

Took me serveral days do understand this issue since the AVR’s display is hidden to me behind a cabinet door; I even operated the devices with an optical connection for some days since I thought of an CEC-ARC/eARC incompatibility issue between the Sony AVR and Panasonic TV.

No, not that. When I go through set up in my avr, it won’t even recognise an ARC device.

The Vero would be on 24/7 the way I have it configured.
It just tells you TV to shut down when the screen saver activates.

It’s worth a try: HDR Autoswitch causing issues on my LG OLED65C8 - #238 by Kontrarian

1 Like

Just to confirm, when I have reenabled CEC adapter in KOdi with Kontrarian’s settings , all seems to be working okay. Ta

Hi,

I was also very busy and rarely at home.

Coming back to bmillham’s suggestion:

Following bmillham’s suggestion, I disconnected everything except the Vero 4k (HDMI 1) and the sound system (HDMI 4).

Since I haven’t had much time to watch television lately, the test may be limited in its conclusiveness. I have the impression that the problem is less common now, but it still occurs.

I also noticed another situation where the problem occurs: I watched two films in a row on the Vero 4k yesterday. The problem occurred when I switched between the two films. But here it was enough to just restart the sound system.

I haven’t tried Kontrarian’s settings, yet. Is it worth a try?

Best, Markus

aargh, it just happened again: watched a movie on Vero 4k and switched to the Youtube App on the TV… and sound was gone.

Markus

Had my Vero 4k a few months and I’ve had ARC issues since day one, I’ve disabled CEC and GPD lock is enabled and I still have to remove the HDMI lead if I want to get sound to my amp when using TV apps. Such a shame as apart from this issue it’s perfect.
LG 65B7 OLED with a Denon X2200 amp.

I figure that it is probably the easiest solution to plug in the HDMI into the Vero on a need-only basis and unplug it after its use.Don’t think that my family can go through all the required steps to bring the sound on again when I’m on the road during the week.

Best, Markus

Having a read through your posts it sounds like for some reason your TV might think the Vero is an Amplifier and is switching its output. In that manual you posted a link to I saw on page 43 it says “You can always change the name or change the type of a connected device” which sounded very curious to me. I would be interested to know what type of device it says the Vero is before and after you experience this issue. Does your issue go away if you manual set this as a player or recording device?

I have manually set Kodi as a “4K / UHD Media Player” and the sound system has been automatically recognized by the TV as a “HES” (“Home Entertainment System”). I have not experienced any changes by the TV to this configuration, which would be visible by the pictographs that are assigned to each device according to its function.

Best, Markus

I have reset all HDMI on my TV set so that the TV set will automatically recognize them. I also plugged-in the FireStick again into HDMI 2. The physical configuration is now:

  • HDMI 1: Vero 4k
  • HDMI 2: FireStick
  • HDMI 3: Nintendo WII
  • HDMI 4: Sound system

Results from the TV’s auto-recognition:

  • It immediately and correctly recognizes the sound system with its correct name “Philips HTS” as a home entertainment system (a pictograph with speakers)
  • it also immediately recognizes the FireStick as “Amazon FireTV” and its functionality correctly as a media player
  • it does not immediately recognize the Vero 4k: First, it shows only “HDMI 1” as a name and “miscellaneous HDMI” as input source. Then, this changes to “Kodi” as name and “satellite receiver” as input source. I’m not sure why it shows Kodi as a name. I remember that I have enter “Kodi” as a name earlier, which might indicate that it is the only input source, which’s name is not recognized by the TV set. I have no clue why the TV then believes it is a satellite receiver.
    (- did not attempt to auto-recognize the WII since it is mostly turned off anyway and does not have HDMI-CEC functionality which – I believe – is used by the TV to recognize a source’s name and function)

I leave the configuration as-is to see if something changes to test darwindesign’s suggestion:

With that said, I made another discovery right now and was able to reproduce the issue three times, which might provide some opportunity to solve it:
I was trying out Kontrarian’s suggestion:

I first set everything to their default values in the “Screensaver” section. Then, changed mode to “turnoff TV” and set the duration to 5 minutes.

A few moments ago, when doing the steps described above, I played some videos for some moments on the FireTV and subsequently on the Vero. I then changed to the TV to watch live TV (CNN). After a few minutes in a breaking news report about Brexit, suddenly the audio output stopped (i.e, no audio via ARC). It felt like 5 minutes. I then reactivated the audio and changed the source to the Vero to change the duration for the screensaver to kick in to 1 minute. I then changed back to CNN. I tested this twice and used a stoppwatch to measure the time fore the issue to occur: in both test runs the issue happened precisely after 1 minute (i.e., the issue is reproduceable). There were no changes to how the TV recognizes the Vero though (see darwindesign’s suggestion above). From my limited testing it appears to me that Kontrarian’s suggestion might not work for me (unless I failed to follow them precisely).

With that said: there might be different issues relating to ARC. What I mean with that?

  • Sometimes it is sufficient to select in the TV settings TV speakers and then external sound system to get ARC working again. I would call this a lighter issue which is notwithstanding annoying but easy to fix. The problems described above with the issue occurring presumably due to the Kodi’s screensaver were such easy to fix issues.
  • Then there are the issues that take more efforts to fix like unplugging HDMI, restarting the TV.

I’m not sure whether these issues have the same root cause or are related.

Best, Markus

When disabling the screensaver all together, it doesn’t happen - am I getting that correctly? From your testing it sounds like the turning off TV functionality is the culprit here.

Yes. I first wanted to make sure that there aren’t any odd Screensaver settings. That’s why I set everything in this section to their default values. Subsequently, I set the screensaver to turn off the TV after 5 or 1 minutes, respectively. Strange thing is that the Vero interfered with ARC even though I changed the source to ordinary TV apparently due to Vero’s screensaver timer.

(at least I think this is strange and unexpected).

M

All other screensavers don’t produce this behaviour - like, let’s say, dim?

Correct.

Reading up in this thread, it seems that only a few TVs have this issue… As long as we can’t reproduce this here, it’s probably very difficult to look at ways to fix this.

In the meantime, maybe switching to a different screensaver is the solution. I’m using the black screensaver with my plasma TV which prevents burn-in effectively. After watching a movie or a TV show episode I’d turn off my TV and AVR anyway, so no need for the Vero to do that. What’s different for you that you need the Vero to do the switching off?

I set the screensaver in that way in an attempt to get rid of the ARC issues, which according to this thread appear to affect different brands of TVs. To set the screensaver in such a way has been suggested here:

I was just surprised by the result and that the screensaver interfered with ARC. Maybe the other problems with ARC are not related to the same root cause. With that said ARC problems appear to be rather common.

So, no, I don’t need the screensaver to be set up in such a way. It was just an attempt to try something that was reported to work. I reset the screensaver to dim.

I didn’t mean to distract anyone with my post. I thought this might be worth mentioning since it affected ARC (at least to my surprise) and is reproducible.

M