Vero 4K multiple problems

I bought a new TV last month and would like to upgrade my media player box. My main usage is to use KODI as video player to watch recorded video stream from my PC. After a lot of research, I decided to choose Vero 4K, since it meets all my needs and easy to setup and use.

Just received my Vero 4K yesterday, the setup is easy. However I experienced a lot of problems when using it and the overall experience is very disappointed.

  1. During initial setup, I changed the language to Chinese. It results the KODI GUI to display only . I understand from my previous experience, you have to change the font to be Arial based, but with the language set, I was not able to find where to set it.

I did not find out how to initialize the settings. The only thing I could do is blindly browse all options and it took me 60 minutes to figure out the way to set font. If there is a way to reset the box to factory default will be great.

  1. The KODI GUI resolution has to be set as 3820x2160 to display correctly. I tried 1920x1080 and 1280x720, both GUI will show out of TV screen. I have a picture here to show the difference.

This is the picture shows 3820x2160 display correctly.

This is when set to 1080p, the time is out of screen.

I could stay in 4K resolution, however it seems the GUI is acting a bit slower than lower resolution. Is there a way to fix this?

  1. When play the video from my PC, 99% of the case, the color is not correct. It looks kind of red. I am not sure what the problem is, it happened on one new box I got earlier, the color is kind of green, so I returned it.

The same video played OK on my old box, which use android xbmc 13.1

The video looks like this:

This is the color from my PC monitor, which is good.

The KODI GUI displays OK, only the video playback. I only found one video which plays correct color. It is a sample h265 HDR clip from SONY.

Is there any setting to calibrate the color?

  1. I use a wired connection on the box. Tried play 3 mins 658MB 4K video. The playback is not smooth at all, it first buffers for more than 30 secs and the video is stuttering and lagging. If I use wireless connection, will it help??

The first day with Vero 4K is not very successful. Hope these problems can be fixed with adjusting settings.

Search the forum there are multiple threads about this problem :slight_smile:


Sorry to hear you are having issues.

If you wish just to do a full reset on kodi settings, the easiest way would be from the command line

sudo systemctl mediacenter stop
sudo mv .kodi kodi.back
sudo systemctl mediacenter start

for a full vero4k factory reset.

For more help setting up the vero4k go here.

As for the colours when playing and the resolution. You will probably need to adjust the colour settings on your tv and as for the resolution, The TV should have different view modes; which should help things fit better.

Thanks Tom.


Thanks for letting me know. Which skin did this occur on? If it’s the OSMC skin, we can probably make this more intuitive.

We recommend running the GUI at 1080p. OSMC will switch to 4K if you watch a 4K clip. Kodi’s scaler isn’t very good, and a lot of TVs do a better job upscaling than Kodi does.

Check your TV settings. Make sure you have 16:9 or Just Scan on.

There might be some contrast settings on your TV.
Also worth knowing if running echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb helps.

I suspect this is one of those sample clips with a very high bitrate. We’re improving the playback performance of those clips in the next update.

Does the colour only look bad when Adjust Refresh Rate is on? Some TVs (such as my LG) have different colour settings per refresh rate, which is a tad annoying. If you’re watching HDR / BT 20.20 content, we’re working on some fixes to make sure the colour output is passed properly in the HDMI header.

Also make sure your device is up to date so you have the latest improvements.


I tried change settings on TV, when I turn HDR+ on, 2 and 3 are both fixed. I am not sure why.

just found another problem, I turn CEC on and the first time it works well with the TV remote. I set the box to suspend when TV is off, the next time I turn TV on, remote will not work unless I restart the box.

all my software are up to date

Currently the Vero4K doesn’t support anykind of “suspend” so therefore I suggest you disable that CEC function.

I don’t mind to leave the device always on, as far as the TV is turned on again, CEC can work with TV remote.

So is it working if you are not setting the suspend option?
Otherwise I suggest to provide debug logs with CEC

Please disable the suspend option and report back. It’s currently
experimental and not quite ready for prime time.

Was the option enabled by default? If it was – then I’ll make sure
that we ensure it’s disabled for new users



As far as the “red push” goes, many new TVs are set with excessive red as this makes them look better under showroom lighting. Turning red down is one of the first things I do on a new TV

1 Like

From the fact that your TV has an “HDR+” mode, I’m going to take a guess that it’s a samsung. I’ve just been having CEC issues with my Samsung TV (UE55KS7000) and noticed that it didn’t work until I pressed channel+/- on the Samsung TV remote while on the Vero input. That would cause the TV to return to a live TV channel, but then when I returned to the Vero again, CEC was working. It may be a long shot, but could be worth trying that.

the default is set to ignore

the channel button on my TV doesn’t do anything, however I found if I switch source and switch it back to Vero, CEC will back to work. Thanks for your hint.

Interesting. Guess that means it’s more the switching sources once that fixes it on Samsung TVs. Strange behaviour, but glad it helped!

Wonder if there’s been another sneaky Samsung update to
send us on another wild goose chase.