Vero 4K+ need help with video calibration

Vero 4K+ video was calibrated. I know it needs to be done per resolution but after changing almost daily I took a better look. Two main issues:

Gui and playback image are fine, but when playing video the controls are off screen.

TV is set to 16:9, no zoom or adjustment to full screen.
Weird thing is that if I press pause, go to settings and calibrate that it shows me a perfectly calibrated screen.

TV set to 1080p/60. When playing video tv info shows 1080p/60 (both when playing video with controls off screen and with calibration screen.

What is the make/model of the TV

Normally you are looking for something called :“Just Scan”, “1:1” or something similar.

Do you mean overscan setting, you should not use that.

It is a Samsung UE65NU8000.
Screen is set to 16:9
Screen adaptation is set to non (can also be on or auto). text says “increase image to fill screen”

with perfectly calibrated screen I meant I get the calibration image and the top left and bottom ricght alignment marker are in a perfect spot (I always hide 1 pixel of the image you are moving in the corner: 1 pixel up/down and left right

As I wrote, you should not use any overscan or calibration setting in Kodi/OSMC. I suggest you reset that.
Looking at the manual any of this setting must play foul.

Thanks, I reset video settings. Issue still occurs (when paused, controls are off screen)

Then it must be one of the magic settings on the Samsung. Maybe another Samsung owner read this and have suggestions.

Try another HDMI input.

Will have to try but TV is against the wall so not easy to do. Googled a bit and read that guisettings xml file needs to be deleted to delete calibration settings. Will check that first.

Apologies if this is blindingly obvious :slight_smile: but one thing it took me a little while to realise is that calibration settings are stored per resolution and per refresh rate; so 1080p/24, 1080p/50 and 1080p/60 all have different settings. Resetting to default for one resolution or refresh rate may not affect others.

Also, this:

that sounds like it’s almost certainly the wrong setting.

Indeed. This is a bit of a pain sometimes.

Thanks. This setting is set to "none (or off) so tv is not doing that. TV Interface is in Dutch, switched to English now:

Opened guisettings and found two resolutions I used that had overlay settings other than 0,0. Reset them all to 0,0 and changed the gui to 1920x1080 for all. saved and rebooted. Even went back to check the settings are still ok (and not overwritten on reboot or something)

As you can see in the picture above part of the kodi gui is now offscreen (icons for movies etc are just a bit cut off). TV scaling off and guisettings all reset. Weird. Can’t easily try the other HDMI ports.

It looks like regardless of settings, your TV has a bit of overscan. You can test this by going in to the Kodi settings for adjusting the screen and seeing if the markers at the top left and lower right are visible. Don’t change anything on this screen (just hit “Esc” or “Back”), but use it to see.

If the markers are offscreen on both sides, your TV has built-in overscan in the mode you have selected. You might need to reach out to other Samsung owners (maybe in a forum somewhere?) to see if this can be disabled using the TV settings. If not, you will have to then use the Kodi adjustments to fix it.

1 Like

Thanks all.

Indeed markers are off screen as suggested. Have been googling more and seems “screen fit” should be set to ON rather than OFF.

With screen fit ON everything fits fine (all video calibration settings still “reset” so no calibration performed in kodi. Sounds counter intuitive but seems to work so far.

Found a thread in kodi forums where this helped as well : Interface is zoomed in during video playback

Settings tv has for “screen fit”

Also samsung is a bit cryptic on this setting. No definition of what ON, OFF or AUTO do but they suggest it must be used for HDMI signals. I guess ON at least makes that stable (fixed settings), where auto might have it change.

Appreciate the help narrowing this down. Will see for the next few days if it is really fixed now (rebooting, various videos)