Vero 4K + network speed major disappointment

Hello all,

Yesterday I received my vero 4k + and after initial setup I started mounting my Synology NAS via fstab. The vero did indeed mount my NFS shares but then the problem started. First of it was real slow reading the shares but worse; it would not play any movie but just froze up. This was all on a wired connection through a switch. I tried rebooting everything (router,nas,vero) but still no joy. I checked my raspberry pi with the same fstab setup and also wired on the switch and it played just fine.

I connected the vero straight to the router but it kept freezing up or just keep loading any movie I wanted to play. Getting a little bit desperate I started to tinker a bit with the fstab file but knowing not much of Linux I kinda of messed it up and decided to start fresh and I reinstalled Kodi through the OSMC installer also hoping this would resolve my network problem. Sadly this was not the case. So i turned to the wireless connection an to my surprise everything was working perfect. Really fast and responsive.

So now I’m beginning to think that I 'm having a problem in my network. Today I bought a new cat 6 network kabel and tried again connecting the vero straight to the router and unplugging everything else besides my NAS. But again the very same problems occurred.

I am now at the end of my wits. I read on the forum that an Iperf test wil come in handy for this so I am trying to google my way into this because I am not familiar with this but I think I’ll manage. So let’s see how far I get with that. In the meanwhile I will provide my logs in the hope someone can figure out what’s the problem or if there’s something I am just missing. Any advice will be most welcome.