Vero 4K NFS Share macOS Big Sur

Hello,

I just upgraded to the latest beta of MacOS BigSur. I use a tool called NFS Manager to set up the NFS Server on my Mac (it is just a front end to set up MacOS as a NFS server).
The Zeroconf-Browser on my Vero 4k shows the directory of the share on my Mac. I just can’t enter the directory itself, where the actual files are stored.
I also own a AppleTV with a tool called Infuse installed. I can access that same nfs share without any problems with that program.
I suspect that Apple changed something with the NFS implementation in BigSur which OSMC doesn’t quite like.

Any solution for this?

Bye.

Do you have any other Kodi devices that are impacted with this?

Hi Sam,

I installed Kodi on my Samsung Galaxy Note 9. It doesn’t work either. So…it’s a Kodi specific problem and not OSMC specific.

I googled a bit and the only thing I could think of is the path for the share. I added the following (which is also discovered by the Zeroconf-Browser):

nfs://192.186.1.10/System/Volumes/Data/Users/alex/Video

That worked before. I can click on the path put the folders inside the share don’t show up.

Bye.

Suggest to login to the command line and run showmount -e 192.186.1.10 to verify the NFS status of the server.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Hm…The Vero4k is running as a client. The server is my Mac. The status of the server can be observed in the NFS Manager app.

As I already explained:

The share can be accessed via the AppleTV (Infuse). OSMC and Kodi on my phone have the same problem. I can’t open the subdirectories in the share.

Hm…maybe just follow the tips that are given :wink:

Okay, okay…

osmc@osmc : ~ $ showmount -e 192.168.1.10
Export list for 192.168.1.10:
/System/Volumes/Data/Users/alex/Video (everyone)

From what I know ‘everyone’ is not equal to ‘*’ so not sure if that impacts it.
It might also be a version issue. Maybe can try fstab or autofs mounting to see more details.

Alternative enable debug logging on Kodi to check if any errors been shown.

The Log looks like that…

2020-09-06 11:51:47.871 T:4064239616 ERROR: NFS: Failed to mount nfs share: (mount/mnt call failed with “RPC error: Mount failed with error MNT3ERR_NOENT(2) Operation not permitted(1)”)
2020-09-06 11:51:48.853 T:4064239616 ERROR: NFS: Failed to mount nfs share: /System/Volumes/Data/Users/alex/Video (mount/mnt call failed with “”)
2020-09-06 11:51:48.854 T:4064239616 ERROR: GetDirectory - Error getting nfs://192.168.1.10:2049/System/Volumes/Data/Users/alex/Video/
2020-09-06 11:51:48.854 T:4064239616 ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.1.10:2049/System/Volumes/Data/Users/alex/Video/) failed

Well not much info there. Maybe you get more info with debug logging enabled.
Or if you try autofs we might get a clearer picture.

Before you try autofs, which can create its own complications, I’d recommend that you try to mount the share from the command line:

sudo mkdir /mnt/video
sudo mount -v -t nfs 192.168.1.10:/System/Volumes/Data/Users/alex/Video /mnt/video

The use of port 2049 might be an issue, so if the above fails try:

sudo mount -v -t nfs -o insecure 192.168.1.10:/System/Volumes/Data/Users/alex/Video /mnt/video
2 Likes

sudo mkdir /mnt/video
sudo mount -v -t nfs 192.168.1.10:/System/Volumes/Data/Users/alex/Video /mnt/video

That worked (so no firewall problem).

I think that this is a problem of the beta version of MacOS.

Also:

I can access the share but my MacMini ends in a kernel panic. This is known. Hopefully the next beta will fix this.:slight_smile:

I tried that. Unfortunately there are not more information to that error in debug logging. Until the NFS bug is fixed I will stop trying to solve this. Doesn’t make sense.;-/ Thanks so far.

The bug is fixed with the latest beta. I used this tutorial and it works:

Thanks:)

1 Like