Vero 4k+ No optical output after August Update

After updating to the August update, the Vero is no longer outputting audio via the Optical out. I have tried a complete re-install from a disk image, and the bug is still present.

I am outputting from the Vero into a Arcam CDS50. Before the update it worked absolutely perfectly, but since the CDS50 registers as having ‘no input detected’. I have tried disabling HDMI audio output, but that does not help.

My debug log is here:

Thank you.

If you set audio output to Fixed and samplerate to 48kHz does it work, then?

Thank you for the reply.
I’ve just tried that, but the CD player still registers ‘No input’.

OK, thanks. FYI I’m listening to Adele resampled to 48k and it’s fine but I did have issues with 44.1k which I’m looking into.

I take it you do see a red light in the cable?

Any other receiver of optical you can test on?

Once again thank you for such a quick response.

I feel like a total fool now. I tried the cable on my amp and it was working fine. Put it back in the CD player and rebooted and the CD player is now also receiving audio.

It’s weird, as I tried reseating that cable about 5 times before I opened the thread and it didn’t work. Switching device and then going back again seems to have done it though.

Could be my cable is on the blink and it just so happened to have started failing the day I updated.