Vero 4K - no playback (overnight) - Audio problem, no ALSA sink?

Everything has worked fine uptil this morning. Watched TV series last night and this morning problems.
Playback starts, but struggles and then stops/freezes after just one or two seconds.
No audio. Also tried playing Music, same effect - no audio. This also applies to other playbacks like from the TED plugin.
My guess is that it is audio casing the problems. As you see below it can’t find any ALSA sink for the channel layout.
I have auto update on so maybe … This morning trying to fix I updated to 11.1.
But no change.
Audio out in KODI is set as default and Passthrough.

Log files -

This repeats (many, many times) from kernel log
Jan 05 12:57:50 vero4k kernel: audio_dsp: buf=2
Jan 05 12:57:50 vero4k kernel: audio_dsp: IEC958_mode_raw=2
Jan 05 12:57:50 vero4k kernel: audio_dsp: IEC958_mode_codec= 1, IEC958 type 2 CH PCM
Jan 05 12:57:50 vero4k kernel: audio_dsp: last mode 1,now 1
Jan 05 12:57:50 vero4k kernel: audio_dsp: putting chip back to PCM state

And this is from playback
INFO: CActiveAESink::OpenSink - initialize sink
DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:hdmi:CARD=AMLM8AUDIO,DEV=0
INFO: CAESinkALSA::Initialize - set digital_codec 0
ERROR: CAESinkALSA::Initialize - Unable to open the requested channel layout
DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:default
INFO: CAESinkALSA::Initialize - Requested layout: RAW, RAW
INFO: CAESinkALSA::Initialize - set digital_codec 0
ERROR: CAESinkALSA::Initialize - Unable to open the requested channel layout
ERROR: CActiveAESink::OpenSink - no sink was returned
ERROR: ActiveAE::InitSink - returned error

Further info:
7.1 Audio through a Marantz AV7701
Have optical connected to Marantz and HDMI goes via TV (LG 65" 9C) since for some reason
if I let the video run through the Marantz i get a blue tinted screen (different issue).

Anyone, please?

Thank you

You have your audio channels set to 7.1 and the optical connection your using only supports 2. Additional to that HD audio format passthrough is not supported with that type of connection. More information can be found in the following guide.

I also noticed that your Video settings were not optimal. We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

I see you have turned off ‘Use limited colour range’. That’s not correct unless you are using a PC monitor. I can’t say that will solve the blue tint but worth a try.

Thank you - but the thing is I have had these settings and connection setup since I got the new TV (this summer). Initially I had big problems with getting audio to work but then I found a working setup and have changed that since. Note. I did try changing output to 2.0 this afternoon but still did not work.
I have now switched back and forth (setting and cables) and are sort of back to my original settings.
I have audio but now OMSC shuts down when I try and play 4K HDR material. I will have a look in the logs and see what I can fin out.
For now I will run the HDR directly from NAS to TV.
Note: Changing the resolution actually fixed the “blue” tinted screen thing going through the Marantz. But I don’t think I can have the video signal going through the Marantz since it does not support 4K HDR passthrough.


The crashing on UHD playback would require more information to comment on. As for the audio setup with an older AVR their exists an option to use an hdmi splitter so the TV and AVR each get the same signal but one that does not have to travel through the AVR. In this way the TV can receive the full quality image at the same time the AVR is able to take advantage of the full audio capabilities it supports.

The Marantz information sheet on your AVR is annoyingly silent on what video standards it supports but reading between the lines I’m guessing it’s HDMI1.4 which does 4k up to 30Hz. You could try ssh into Vero and typing

echo 1 | sudo tee /sys/class/amhdmitx/amhdmitx0/force_hdr

That may let you play (most) 4k HDR videos (ie 4k24Hz) through the Marantz. If you were trying to set the GUI to 4k60Hz and pass that through the Marantz then it’s unsurprising you would get a bad result.

Let us know if that works, or else post logs with Vero connected to the Marantz.

1 Like

@grahamh - the “blue” actually was solved by just changing the resolution in the gui to Full HD.
I will try your suggestion with forcing HDR.

Otherwise @darwindesign is a very good idea with a splitter.
I have not managed to get the audio to work using the ARC in the TV.

Thank you for all the great ideas and help. I will give feedback in the thread but for tonight I am banned from the tv and tomorrow I work a 24-hour shift so I can’t test till Thursday.

I just wonder what has changed since everything worked fine last night…


That would be quite hard to say. OSMC will not update without user confirmation regardless of settings and I don’t see how the settings I saw in that log would have worked with an optical connection to your AVR. Also the only outcome where I can conceive of where an update might change your audio settings would be if guisettings.xml was reset to default values but default is not was is indicated in those logs.

For the most AVR-TV combinations I know on both sides CEC has to be enabled otherwise there is no audio via HDMI from the TV to the AVR. HDMI control is another term for CEC. So, read the device manuals of the TV and the AVR and give it a try.
My Sony AVR in addition starts with the TV channel muted which is some kind of protection … but another ugly trap you can waste a lot of time to understand why audio is missing.

Thank you all for your support and shared knowledge.

I now have everything up and running.
Set up is actually almost back to original. I have it running through the TV and using ARC for audio.
This also means that I can have great 4K GUI in KODI.
(I did order an HDMI splitter, but it does not seem to be needed). See below for the trick for ARC.


  • Changing GUI resolution to Full HD and almost all playback (with audio) worked when connecting through the AVR, including 4K (which the AVR is supposed to support) Only HDR fails (see next point below).
  • @grahamh Force_hdr=1 did not help. The HDR “signal” did not get through the AVR and Kodi crashed trying.
  • Previously I could not get ARC working. But the trick was your info @Profile - JimKnopf - OSMC Forums. That CEC was the same as HDMI Control. There was a setting in the AVR to activate just that. I did not know that that was related to audio return as well.
  • One interesting point though about Optical is having the direct cable connected between the VERO and AVR did have some effect. Without it no audio and alla playback failed. But connecting it (without reboot) and playback an audio (full suround) worked. However rebooting with it connected and it failed again. So something was triggered via that even if the signal did not go that way.

Again thanks for the support.


A quick search in google showed to me several posts/threads stating the Marantz AV7701 cannot passthrough hdr at all.

The point of the splitter would be to use the second HDMI signal to feed full quality audio to your AVR as it supports 8 channel PCM and HD audio formats but neither optical or ARC does.

As mentioned earlier in this thread we do not recommend running the GUI in 4K.

TBH that’s what it should do according to the HDMI spec (reject metadata it doesn’t understand) but my old Yamaha doesn’t care.