Vero 4k - no power

My Vero4K box

Invoice Date: February 13, 2021
Order Number: 32152

appears to be dead. There is no light. It will not power up. The TV says no cable connected.
I tried a different power point. I tried a different power chord.
nb. The power supply went out today. Surge? Other devices are OK though.


Can you show a photo of the other power supply that you used?

Sorry for the slow reply.
re: the other power supply. I can show you this, but as I tried this after the Vero4k died, I am not too sure how that is relevant. I had the original supply power chord plugged in when the 4K died.
I will get a pic.

That is a 12V output power supply which would have broken the Vero. The Vero Power Supply is only 5V.

ok, so even though it is already broken does that matter? ( I suppose that voids my warranty?)
Can I troubleshoot anything?

Well up to that moment most likely only the (original) power supply failed not the Vero, but using the 12V would have blown the protection in the device.

I doubt it but better to have @sam_nazarko to comment.

If you’re lucky – you may still be able to power the device via a USB-A cable; but using a 12V power supply would almost certainly have damaged the device.

I have a million cables - but no suitable USB-A cable.
Is it possible to repair the power/device or is toast?

It’s hard to say. If 12v have gone across the motherboard, then the eMMC, RAM and other peripherals will be damaged beyond repair

It’s worth trying with another 5V, 2A power supply.

yeah, before you chuck the Vero in the dustbin try another 5V 2A power supply