Vero 4K no power

What can we do about apparent hardware faults with the Vero4K? It no longer powers on - no blue led or anything.

I’ve tested the power supply and get 5V out of it. Don’t have another power adapter to test at present (new 5V/2A supply arriving tomorrow) but I fear it might be the Vero itself, though it’s only 7months old.

No changes made before it stopped powering up - been sat happily behind my TV since I got it.



I’m sorry to see you’ve experienced a problem. Do you have a previous report of this issue?

If your Vero is only seven months old, it won’t feature a blue LED. As the Vero 4K+ only has a red LED which is only illuminated for 2-3 seconds when the device is booting.

I’d suggest reinstalling OSMC first and seeing if it’s detected on your network. You can check this via your router status page.



Apologies r.e. the LED - shows how often I looked at it!
When plugging in the power, no LED’s turn on.

It didn’t appear on the network (through a network cable) originally when I posted and no network activity lights on the network port (assuming there should be).

For completeness, I’ve just inserted a microsd card with the latest image for the 4K, and plugged in the power, but again, no luck. No LEDs, nothing on screen, nothing on the network. Nothing that appears to show any power in use by the device.

I’ll try again with a fresh power supply tomorrow, but failing that, any other suggestions?

See if there’s a red light coming from the back by the optical port

Hey, I know it’s been a while.

Since we last messaged, the Vero4K has been working fine so decided to leave it there.

Unfortunately, yesterday I went to use it and the screen was black. Unplugged the device and plugged it back in but it won’t power back on. I’ve tried with the original power supply and an alternative 5V 2A power supply purchased during the last time these issues occured.

Left the device off & unplugged all day and tried both power supplies, nothing. No red light on the front, no red light on the optical port. Have already confirmed both supplies are working with other devices.


What were you dong with it last?

I’d try power it via a USB-A cable.


Last use was general usage (playing media) & left on overnight. No issues were experienced at that time.

I’ve tried a USB-A connection (tried both 5V, 2.4A Max & 5V, 3A Max plugs) - the optical port lights up, but that’s all. Nothing on the front & nothing on screen or the network. Have left it on for 20 minutes.

– Edit 14:00
So, I left the device plugged in through USB-A and hooked up to the TV over lunch, and it powered up with no further input. I know it happened at 13:45 as the channel switched through CEC without me doing anything. At this point, it had been “powered” for around 3 hours.

Now the device is up, are there any logs you want? I don’t want to restart it until then.


Hi Nick,

All logs via My OSMC would be useful.
Is the device still up without issue; does it feel hot?


Hey - I’m slow responding again. Sorry.

it does get warm, but wouldn’t call it hot. Certainly not to be worried about.

I happened to catch it crash today with the following;

Removing and re-inserting power did bring the device back up & seemed OK. Unfortunately I wasn’t in a position to do anything to investigate at the time.

A few hours later, the screen when blank, with no availability on the network (Fibre light on the back was lit) - restarted again and seemed OK.

At this point, I performed some checks for badblocks on based on the above image.

root@osmc:~# badblocks -v /dev/vero-nand/root
Checking blocks 0 to 14864383
Checking for bad blocks (read-only test):
Pass completed, 0 bad blocks found. (0/0/0 errors)

When attempting it on /dev/dm-0 the system goes into ReadOnly & everything I attempted straight up failed.

The screen also went blank on the TV.

I removed power & plugged it back in. Now there are no lights on the device (front or back) - nothing on screen. Tried with both 5V power supplies & over USB-A.

Before it went RO, I did managed to upload logs to if that’s of any use.

The next time it comes back up (if it does) I’ll try and grab logs again, but then I’ll rebuild it from a Micro-SD card unless there’s anything else you’d like to check first.


Is there attached media on the device?


Nope - all media is through SMB shares.

Been trying to turn it back on, but keeps displaying only a black screen. Tried all 3 power supplies;
2x barrel jacks - no lights anywhere
USB - front light doesn’t turn on, Fibre light turns on

Left them all for at least an hour and nothing.
I’ve just plugged in the microSD and left powered on via USB to see if that triggers anything - left 10 minutes so far with nothing.

I’d try reinstalling OSMC if you can

If it would power up to the point where I could, then I would.

I’ve tried 2 different 5V power supplies, plus a powering over USB (all worked occasionally before this weekend). All of which show no LED on the front when plugged in, and the Fibre port lights up on the back.

Tried different HDMI Cables (known working) through different TVs & Monitors to confirm that there is nothing being displayed anymore.

Plugged in a microSD card to reinstall OSMC, but still nothing appears on any screens (which makes sense as it doesn’t even appear to be booting to a point to display anything to screen)

To me, this is all pointing to a potential Hardware issue. I am more than happy to try anything else you suggest, but as it now won’t even boot to a splash screen or some kind of recovery prompt, not sure what else I can try?

Do you have a USB-A cable? The device can be powered via USB


I have, using both a 5V, 2.4A Max usb-a to usb-a socket & 5V, 3A Max usb-c to usb-a socket. The second one worked for approximately 1-2 weeks previously to this latest spat of “blank screen” issues.

Any attempts to power up has been rotating between 2x normal DC power sockets (one of which was supplied with the device) & 2x usb sockets - so 4 power supplies in total.


I’m surprised USB-C to USB-A worked at all.

I think you have a hardware problem if you can’t power it via USB-A or barrel jack.

Needs a usb-c to usb-a female adapter in there as well, then usb-a male to usb-a male. Tried it as that was the only way I could ensure 5V/2A over usb-a at the time. Worked fine for a week or so, even with a powercut in the middle.

What happens now? The unit is only ~10 months old.

If your device is only 10 months old, it’s more than covered under warranty.

Get in touch via with your order # and we’ll take care of it



Thanks for your help troubleshooting.