Vero 4K+ "no signal" drops during 4k/HDR playback H265

Hi Team,

A while ago I can’t play 4k / h265 content, the signal drops recently, there isn’t a continous 5s which is played correctly.
I have absolutely no issues with 1080p h264 contents, all works fine.

Chain: Vero 4k+ – HDFury Arcana (eARC – Epson TW8400 projector & Sonos ARC


Could you please suggest what to check/change? I did several hours of searching, tried different configs but no luck so far.


  1. Try enable Use limited colour range (16-235)
  2. How long is your HDMI cable?


Hi Sam,

I have the same experience with limited color range as well, just set to this value yesterday to unlimited.

HDMI cable lenght between Vero & Arcana is 0.5m.


How far is the cable to the projector?

When there is a dropout, is it reflected on the HDFury display?


The cable to the projector is cca. 2m.

Hdfurry shows the signal lost and back on this sequence:

Independently to the fact if the projector is connected or not.

I recognise 3 different stete on the attached video:

no signal,
444 bt2020 8bit,
444 bt2020 10bit HDR

If I plug directly the projector to the Vero, I have no issues with the picture (and obviously I have no sound).



You asked questions so many times about the HDMI cable that I made a try: after changing the short cable to an other one between Hdfurry and Vero the issue seems to be solved, your initial got feeling was absolutely correct.

Thanks for the great support!


I’m glad to hear this.