Vero 4k - No sound

I have had the Vero 4k for several years now and it has been more or less flawless. Yesterday, however, the sound suddenly stopped working while playing any form of content. I rebooted, changed HDMI cables, changed HDMI ports on the TV, all to no avail. I eventually discovered that leaving the device powered off and disconnected for awhile and then reconnecting would give me sound for a limited time. It would play sound for, say, one episode of a stream but going to the next episode sound was again gone. (ps GUI sounds still work)
Any advice would be appreciated although I’m tending to think the device may have reached its end of life! Cheers Jon

I can’t recall anyone else losing sound as a result of hardware failure and would think it’s unlikely. If you can turn on debug logging and post logs when it happens again we could take a look.

Hi. I’ve turned on logging and uploaded. They are at
Let me know if that is the correct logging.
Many thanks Jon

Yesterday I re-installed osmc on the device to check if the os had been possibly corrupted in some area affecting the audio. Alas, the problem still exists. Sound for one instance of play and then none. Again shutting down and leaving off for a while brings back the sound for a further instance before sound is lost again.
So again it would appear to my limited knowledge that there has been a hardware failure.
Any further advice or information would be appreciated.
Thanks Jon

No. You must have copied it wrongly. Can you have another go?

We can’t access the logs using the URL provided. Can you please re-check?

Sorry for the delay in reply. Took a while for the problem to reoccur.
The log is located at

Many thanks Jon

Just wondering if anyone has had a chance to look at the log file? I would like to know if the device can be fixed or whether I will have to replace it.
Many thanks

Have you tried with a local file? You could try a demo like Big Buck Bunny to rule out an issue there.

Unfortunately because you’re not using local content (you are using an add-on which allows you to access copyrighted material), we weren’t able to provide much feedback. If the issue can be reproduced with a file locally I am sure we can help

OK, thanks for that. I will try that asap and get back to you.

Ok I have played Big Buck Bunny locally and the log is at


Did you hear audio?

No there was no sound.

Have you tried with a fresh install of OSMC?


Yes I did a fresh install. I’ve also tried new HDMI cable and different TV port. Still no sound. Initially, if I left the Vero unplugged for some time it would work again for a short while. However now the audio seems to have stopped altogether.

  1. Not sure why you have this setting Number of channels: 2.1?
  2. Are you hearing the key clicks?
  3. If you plugin a headphone into the analog out does it work?
  4. Does your TV have a SPDIF and do you have a optical cable to test that.

Yes I can hear the GUI sounds. I have a soundbar attached through the SPDIF port and there is no sound through this. (I have also tried through the TV speakers without success). I have wireless headphones attached via analogue-out switch (there is no analogue port on the TV) and again no audio.

Directly to the Vero? If so you would need to change the Audio Out for that test.

Not sure what you mean here. I was referring to just use normal 3.5mm cable headphone directly connected to the Vero.

Ok, that would indicate just a configuration issue or capability mishap

Ah sorry I got the wrong end of the stick! I had everything sound related running from the TV and only the HDMI connecting Vero to the tv.
On connecting the SPDIF directly from Vero to the soundbar has indeed got the sound working. Also the analogue speaker connection directly from Vero is working. So it appears the HDMI from Vero is no longer sending sound to the TV and through to the sound bar etc.
So thanks for identifying that. My only problem now is finding a way of connecting both TV and Vero to the sound bar and headphones! That’ll keep a 69 year old brain busy for a while.
Thanks for the help