Vero 4K not booting

I have a Vero 4K that has been working perfectly for several years.
Recently I’ve had it disconnected for a while and when plugging back in again now, it won’t boot.

When I plug in the power, I see the front red light slightly flickering. No output on HDMI at all.

To check if it is the PSU failing, I’ve tried powering it through the white USB port.
This results in a constant on red light and it seems like something starts outputting to the HDMI port, as my TV registers that the port is active. I however get nothing on the screen (no boot screen/please wait/etc) - just black.

I’ve disconnected everything else (USB dongles, ethernet) to be sure nothing is acting up.

Any ideas for what my next steps would be in troubleshooting this issue?

I haven’t bothered checking the voltage of the PSU yet as I figured I wouldn’t really get any further if the Vero won’t even boot via USB power.

What’s on the other end of the USB port?

If it’s an old phone charger – it may also not be delivering enough power to start the device.


Hi Sam, thanks for replying :slight_smile:

I have it connected to an USB 3 port on a fairly new laptop as I wanted to make sure it delivered enough power. The only USB A-A cable I could find is however marked as USB 2.0. As far as I could find out, it shouldn’t really make a difference (and the cable is only 1M length) and it shouldn’t be a limiting factor?



This shouldn’t make a difference.

If you plug the USB in to the white port on the device, does it show up under Device Manager?


No - I see no difference in any devices in the Device Manager, and I also do not see any notifications/popups as you’d usually see when attaching a device through USB.

You could try another 5V, 2A power supply if you have one, but it sounds like the device is experiencing a problem.

Yep - I’ve tried finding one but I don’t really have one at hand now.

I could measure the output of the one here to confirm if it is providing what it should, but my guess was just that it wouldn’t really matter if the device could not even power on/boot via the USB port.

Do you have other suggestions as to what I could try to determine where the issue could be in the device itself when it isn’t even detected when connected by USB?

The device would only be detected on USB if it was in a bad state and fell back to burning mode. Otherwise it won’t present itself as an OTG device. This was just to determine if the device’s filesystem itself had become severely corrupted. It does not sound like this is the case.

So just to be sure I understand you correct - there’s not really any other options to look into for further troubleshooting the issue on my device.

I guess that removes my final excuse for why I should not get that 4K+ :wink:

Unfortunately we’re limited on stock at the moment, but we are getting some in soon (Monday with any luck).


I was actually super lucky to find someone here who was selling an almost unused 4K+ at a very good price. He realized after 2 hours of use that it didn’t fit his needs for Dolby Vision.

I can however confirm that my old unit is completely dead even with the new power supply and that the old power supply seems to be just fine with the new unit.

Sorry to hear this.