Vero 4K+ not recognising external HDD and not uploading iptv channels

So, I finally reinstalled the OSMC successfully. But the troubles continue.
Without anything pluged the vero after a few minutes shutdown. Then I tried to connect the hdd and it didn’t recognize it and it shutdown again. After I pluged the usb port with the hdd and could make it work. Added the library and I am now wacthing a tv series. I don’t no for how long, though…
How do I send you the logs?

You have received that information, in post 15.

When the device shuts down:

Do you see any lights on the front of the device?
Is the unit or power supply warm to the touch?



There’s no light at the front and the Vero is a little warm, but not to much.
Yesterday I watched a few episodes of a series without any problem. Today it worked for like 5 minutes before it shutdown. And in both cases I had the USB hub connected.

The logs should provide some clues here.


I’m sorry, I’ve been working 16 hoursa day and hadn’t much time to play with the vero.
I’ve learned to upload the logs, so this weekend if anything happens, Ill upload them .
Thank you.

1 Like

Hi there, here’s the log

Now it turns off as soon as I turn it on…

This is the log file without HDD or USB hub on the vero

Disable the Library Watchdog add-on as a test, as that can cause excessive CPU usage.

The real issue: it looks like your hub is not conformant. I think that this will cause problems.

How do I update my library then?
Do you think it’s best to buy the one on the Vero store? I didn’t buy it because you guys weren’t shipping it at the time…

He suggested that as a test. With Watchdog disabled you can just do a manual scan.

I’ve removed the Watchdog and it still doesn’t update the library. I’ve removed the usb hub and still no update and it turns off showing that sad face…

You don’t need the watchdog add-on to update your library.
The hub may have caused damage to the Vero, and you may need to open a support ticket regarding this matter.

I would try a reinstallation with no peripherals, no add-ons attached and try and run the device for 48 hours.


Ok I’ll try doing an reinstallation and see how it goes. Thanks.

I’ve reinstalled with nothing on and on first attempt it didn’t even finished. At the second try, installed successfully, but the troubles continue…


I’ve opened a support ticket regarding this matter.
What happens now?

I’ll follow up there.