Vero 4K+ not turning on

This seems like an issue with the TV reporting it capabilities, maybe related to your previous HDMI issue.
Suggest to power down both devices. Then Power on TV first before power on Vero.
Also generally the GUI will be configured at 1080p. For 4k videos to play at 4k you need to set “Adjust Refresh Rate to On/Off”.

2 Likes

Thanks for the info, I’ll try that when I get home. With regards to the:

For 4k videos to play at 4k you need to set “Adjust Refresh Rate to On/Off”

What do you mean? I can see the greyed out Refresh Rate that seems set to 60. Might be obvious once it becomes enabled after a reboot but just trying to preempt the situation where I may still not understand. Thanks again.

Yes after reboot the greyed out should change to 1920x1080 and become changeable. But basically you should keep it at 1080p as it is best performance and the TV Upscaler will be better. Just to ensure 4k Videos will be sent in 4k you would need to enable the option “Adjust Referesh Rate” to “At Start/Stop” (seems I mistyped before). This option is in the Video menu not Display

1 Like

Gotcha, will try that when I next get a chance. Thank you.

Ah great, yes rebooting the unit with the TV on sorted the problem. There’s another issue, it cannot seem to find my network attached storage device.

When I go to Settings > System Info > Summary, I can see that it has correctly picked up an IP address from my router. But it won’t allow me to find my storage when I try to add my network location. I’ve tried SMB as well as NTS but neither option work.

My previous Kodi device (using a Raspberry Pi) found the shares via SMB correctly. Having done some Googling, I found this page: Configuring fstab based Samba share mounts which recommends using FSTAB. I’ve never heard of FSTAB but if these instructions apply for the Vero 4K+ then happy to follow the instructions. They’re not very user friendly so just wanted to check there wasn’t a better/easier way before I dived in.

Any help/suggestions?

  1. For NFS you would need to confiugre yoru NAS to allow the IP of the Vero4k+ to access it!
  2. For SMB share browsing is not supported as SMB1 is disabled by default I suggest to read this wiki entry File sharing with a NAS, media server, windows share or other device

So if you want to stick to Kodi Share approach you might need to set protocol as SMB1

If you don’t want to follow the fstab approach this is an alternative

1 Like

I just tried to configure one of my shares using the fstab method using the guide (Configuring fstab based Samba share mounts). I added the following line to my fstab file.

//192.168.1.50/Movies /mnt/Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=Kodi,password=bignolembide,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

I didn’t get an error while doing ‘sudo mount -a’ nor during the restarts. However, when I typed ‘cd /mnt/Movies’ it said:
-bash: cd: /mnt/Movies: No such device

What am I doing wrong? Any help? Thanks

Screenshot of my SSH window command:

image

Hi,

From reading through this topic, it looks like the share server is offering smbv1 shares. So suggest try adding:

vers=1.0 or sec=ntlm

berfore 0 0

Thanks Tom.

1 Like

Thanks for the help, I tried that but got the same error. Here’s a link to my log: https://paste.osmc.tv/agakizivay

Install smbclient sudo apt-get install smbclient
Execute smbclient -d 10 -L 192.168.1.15 -U Kodi and report the output

1 Like

I did that, here’s the log: https://paste.osmc.tv/omixahudeq

Would need to see the terminal output, not the log file.

Either copy/paste from your SSH session or use smbclient -d 10 -L 192.168.1.15 -U Kodi | paste-log and provide the URL

1 Like

Hi,

Unfortunately the output of:

is not in the logs,I believe. The output needs to be posted in this topic, a screenshot would do.

Thanks Tom.

1 Like

This is what I got: https://paste.osmc.tv/exubujiwag

Enter Kodi’s password:
Anonymous login successful

Sharename       Type      Comment
---------       ----      -------
Usb             Disk      System default share
Public          Disk      System default share
Home captures   Disk      
Music           Disk      
Software        Disk      
Video           Disk      
home            Disk      Home

So you don’t have a share called Movies which is the one you tried to mount. You only can mount existing mounts from your NAS.

Oh I see, the Movies folder is within the Video folder. I thought I mounted folders.

Well you also can do that but need to start with the share :wink:

BTW I assume you can remove the vers entry

1 Like

Ok, great. Thanks for the help. So I’ve mounted my Video network share (without the vers). I can now cd to /mnt/Video and I can see the contents of that.

A few questions:

  1. How to remove the other failed attempts that created /mnt/Movies (I tried umount /mnt/Movies but I get the error not mounted.
  2. Do I need to revert the install of the smbclient?
  3. How do I now use this new /mnt/Video folder within OSMC? I’m not sure where I need to go.

Many thanks

Hi,

If its not mounted, you can just remove it from fstab and remove the mount point with:

sudo rm -rf /mnt/Movies

sudo rmdir /mnt/Movies

No

Browse to: root file system, mnt, Video

Thanks Tom.

1 Like