Vero 4K+ not turning on

Okay, so I’m just trying to setup my 4K+ which was delivered yesterday. I’ve plugged it into my TV, connected it to my wired network and plugged in the receiver USB receiver. I then plugged it into the mains. The front light shows red for couple of seconds and then it goes out. But nothing is displayed on the TV and nothing else happens after that. I’ve left it in that state for over 5 minutes with nothing going on. I followed the quick start guide very carefully.

Is there an issue? Something else I should be doing?

The red light appears while the boot loader initialises; and then the LED will turn off as we removed the blue LED in Vero 4K +. This means it is turning on correctly. If you attached an Ethernet cable, you’d probably be able to find it as a new device on your router to confirm it’s operational.

Can you try with another display? Do you see a signal on the TV?

Can you try with a known good hdmi cable, etc?

It’s also unlikely, but worth mentioning: make sure you push the HDMI in fully. I sometimes do not do this and get no signal when testing different setups.


1 Like

Hi Sam. Thanks for the quick reply, yes the HDMI was the issue. It needed a bit more force than I was willing to try before I read your message. Needs a very firm push.

Slightly off topic but the desktop resolution seems to be fixed to 720p. I’ve got a 4K TV so I would have thought it would use the full resolution, no?

I had the issue with fixed /grayed out resolution that you couldn’t select or change before, but a reboot fixed the issue for me and made it so I could change it again

1 Like

This seems like an issue with the TV reporting it capabilities, maybe related to your previous HDMI issue.
Suggest to power down both devices. Then Power on TV first before power on Vero.
Also generally the GUI will be configured at 1080p. For 4k videos to play at 4k you need to set “Adjust Refresh Rate to On/Off”.


Thanks for the info, I’ll try that when I get home. With regards to the:

For 4k videos to play at 4k you need to set “Adjust Refresh Rate to On/Off”

What do you mean? I can see the greyed out Refresh Rate that seems set to 60. Might be obvious once it becomes enabled after a reboot but just trying to preempt the situation where I may still not understand. Thanks again.

Yes after reboot the greyed out should change to 1920x1080 and become changeable. But basically you should keep it at 1080p as it is best performance and the TV Upscaler will be better. Just to ensure 4k Videos will be sent in 4k you would need to enable the option “Adjust Referesh Rate” to “At Start/Stop” (seems I mistyped before). This option is in the Video menu not Display

1 Like

Gotcha, will try that when I next get a chance. Thank you.

Ah great, yes rebooting the unit with the TV on sorted the problem. There’s another issue, it cannot seem to find my network attached storage device.

When I go to Settings > System Info > Summary, I can see that it has correctly picked up an IP address from my router. But it won’t allow me to find my storage when I try to add my network location. I’ve tried SMB as well as NTS but neither option work.

My previous Kodi device (using a Raspberry Pi) found the shares via SMB correctly. Having done some Googling, I found this page: Configuring fstab based Samba share mounts which recommends using FSTAB. I’ve never heard of FSTAB but if these instructions apply for the Vero 4K+ then happy to follow the instructions. They’re not very user friendly so just wanted to check there wasn’t a better/easier way before I dived in.

Any help/suggestions?

  1. For NFS you would need to confiugre yoru NAS to allow the IP of the Vero4k+ to access it!
  2. For SMB share browsing is not supported as SMB1 is disabled by default I suggest to read this wiki entry File sharing with a NAS, media server, windows share or other device

So if you want to stick to Kodi Share approach you might need to set protocol as SMB1

If you don’t want to follow the fstab approach this is an alternative

1 Like

I just tried to configure one of my shares using the fstab method using the guide (Configuring fstab based Samba share mounts). I added the following line to my fstab file.

// /mnt/Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=Kodi,password=bignolembide,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

I didn’t get an error while doing ‘sudo mount -a’ nor during the restarts. However, when I typed ‘cd /mnt/Movies’ it said:
-bash: cd: /mnt/Movies: No such device

What am I doing wrong? Any help? Thanks

Screenshot of my SSH window command:



From reading through this topic, it looks like the share server is offering smbv1 shares. So suggest try adding:

vers=1.0 or sec=ntlm

berfore 0 0

Thanks Tom.

1 Like

Thanks for the help, I tried that but got the same error. Here’s a link to my log:

Install smbclient sudo apt-get install smbclient
Execute smbclient -d 10 -L -U Kodi and report the output

1 Like

I did that, here’s the log:

Would need to see the terminal output, not the log file.

Either copy/paste from your SSH session or use smbclient -d 10 -L -U Kodi | paste-log and provide the URL

1 Like


Unfortunately the output of:

is not in the logs,I believe. The output needs to be posted in this topic, a screenshot would do.

Thanks Tom.

1 Like

This is what I got:

Enter Kodi’s password:
Anonymous login successful

Sharename       Type      Comment
---------       ----      -------
Usb             Disk      System default share
Public          Disk      System default share
Home captures   Disk      
Music           Disk      
Software        Disk      
Video           Disk      
home            Disk      Home

So you don’t have a share called Movies which is the one you tried to mount. You only can mount existing mounts from your NAS.