Vero 4K - Not working after March 20, 2020 build update

I updated my Vero 4K with the March 20, 2020 build and the unit doesn’t work right.

  1. the library update is stuck with the word “preparing…” And just hangs.

  2. Videos open and play in slow motion. One frame plays every 15 seconds or so. 100% of movies freeze Ike this.

Navigation in the UI works normally.

Vero 4K is wired to TV and hardwired to router. Videos are located on a 4-bay NAS hardwired to the router. The Vero 4K worked flawlessly for the past 7 months until today.

Help. No idea what to do.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I successfully enabled logging, but cannot figure out how to upload the log file.

Pressing the “Upload Log” button does nothing (i.e. there’s no feedback from the Vero 4K so I don’t know if the button did anything). Nor do I understand how to use SSH as there was no guidance on the prior post (and I couldn’t find anything on the community forum on this subject).

Edit: I didn’t mention in my first post that I use Confluence. Switching to the OSMC skin did not resolve the issue. I’ve tried multiple reboots in an effort to correct the issue. No joy.


Sounds like the log may be to big, I suggest rebooting twice. The reproduce issues and try uploading logs again please.

Thanks Tom.

1 Like

Thanks for the detailed instructions.

I just tried using the OSMC a few minutes ago (~10 hours after my original post) and the box seems to be working fine now. Although, I only tested it for ~10 minutes or so. I’m guessing that saving a log would be pointless since there are no loggable events to capture.

Does the March 20th update do anything that would cause an extended re-writing of the DB? I’m wondering if the unit was tied up performing clean-up work from the update. I’m asking this because my library has over 20K videos w/ locally stored .nfo and artwork files. Something like that would explain the video stream choking (although I did check the CPU usage during the issue and it was minimal ~1% to 5%).

1 Like

No – the database structure is static at the moment and will be until the next Kodi major version (i.e. v19); which doesn’t have an ETA at this time.

Does the update do “anything” that would take hours to reconcile? It just doesn’t make sense that all of the video streams and library update processes would choke after the update and work 10 hours later.

No. Some logs might give some clues as to what’s going on.
There might’ve been a couple of add-on updates, but that’s not CPU intensive and shouldn’t take more than a minute or two.

1 Like

The only other thing (that I can think of ) that makes sense and explains these symptoms is a network issue that resolved itself later in the day. Video streaming and library updates (scanning) are both network intensive tasks… that’s the common thread.

Either the update did something to the network settings that reconciled over time or the mere act of rebooting caused something that temporarily impacted network connectivity/throughput.

This makes the most sense, but I’m at a loss.

Let’s keep an eye on things.

1 Like

Thanks for your support.

1 Like

The problem started recurring


  1. The Vero 4K works fine so long as there is no “Update Library” scan in progress. I’ve had the Vero 4K for over 7 months and there was never an issue playing content while the unit was scanning the local NAS for new content.

  2. After initiating “Update Library” the box in the upper right corner of the screen that shows the scan progress persistently shows the text “Preparing…”. (the box doesn’t show the cycling of new titles like it used to do).

  3. When a video is played (while the scanning is in progress) the video plays back at < 8 FPS or doesn’t play at all.

  4. After canceling the “Update Library” scan, videos seem to play normally again.


Actions performed after initiating logging and rebooting 2x:

  1. started “Update Library” scan
  2. started video #1 which didn’t play at all
  3. started video #2 which didn’t play at all
  4. started video #3 which played at < 10 fps
  5. downloaded log file.

That’s not a full log. You only supplied the APT logs. Probably a typo, -a instead of -A

Here you go:

I hope this retained everything from my earlier test.

Verify your paths, there are over 400 entries in the log like this:

2020-04-08 20:04:42.803 T:3863982816 WARNING: Process directory 'smb://DNS-343-SOURCE/Volume_2/dns343-v2-movies/16.Blocks.(2006)/' does not exist - skipping scan.


2020-04-08 20:04:40.745 T:3863982816 WARNING: Process directory 'smb://DNS-343-SOURCE/Volume_2/dns343-v2-movies/' does not exist - skipping scan.

Also, not related but I see that you have the GUI set to 2160 and don’t have refresh rate set to Start/stop.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Thank you.

You solved the problem. I have four 4-bay NAS and one of them didn’t restart after a scheduled power cycle. One of the HDDs in that specific NAS was pathed to the Vero 4K. When the Kodi box couldn’t find the HDD the scan was hanging. Restarting the NAS fixed it

1 Like

Glad to hear! You should still consider changing the GUI to 1080 as I suggested.

1 Like

I changed the resolution to 1080p and the Kodi screen went past the edge of the TV (cut off).

You need to set your TV to ‘Just Scan’ or 1:1 to remove the overscan so the GUI shows properly. You may have to search for that setting as some TVs have it buried or in non-obvious places.

If you let us know the make and model of your TV we can probably advise more specifically as to what setting you need to change.