Vero 4k only recognizing second play button press after pausing playback

Hello guys,

I’ve noticed a strange behaviour for a while and I thought that it might be related to the IR implementation of the Vero 4k until I switched to controlling the Vero via Bluetooth now: When no input by a remote is happening for a few minutes (after pressing pause while watching a movie and a short time of absence) the next button press (pressing play again) is not recognized… There’s no response, but one has to press the play button again for the Vero to restart playback. It doesn’t happen when pressing play right after having paused the playback. Some time has to pass between the two actions.

This is not a major issue, but it’s kind of annoying. When I return to my TV after having paused playback, I just want to press play and have the Vero continue playback without the moment of “oh, wait, the Vero didn’t take the command again and I have to press the play button another time”.

This behaviour happens with the RF remote, with IR control and via Bluetooth. So, it’s not related to a specific remote or a specific way of remote controlling the Vero. I only noticed it with the play/pause scenario… All other actions seems to be working, but I can test again.

I should add that I use the dim to black screensaver as I’m using a plasma TV which I don’t want to damage when keeping it on for a while… But of course, this screensaver doesn’t get activated when pausing playback, so the first play button press doesn’t “wake up” the Vero from a screensaver activity. Only when no playback is active (or paused) the screensaver kicks in after a short while and only then I can accept and understand a first “wake up” button press. But when continuing a playback this first “wake up” button press is very annoying and seems unnecessary to me.

Any ideas what might be going on here and how it could be solved?


It seems the correct behaviour. One press to make the screen bright, so you can see what you are doing, then another to play.

See Mapping the PLAY key

Well, as I said… It’s during pausing playback. So, the screen stays bright (screensaver is not active!) and I’d actually expect the Vero to stay alert for a very likely play command. But it doesn’t do so.
If the screen saver is active during times other than playback, you’re right (as I also described above).

It sounds like the expected functionality here. You might have more luck on the Kodi forum.

Ok, I did some test and it seems to be as follows:

  1. If you use the OK button to unpause it always would require double press
  2. If you use the Play/Pause button it only would require a double press after 3 minutes

Let me check that since we use the same setup with the harmony hub and the vero … but I doubt I have that behavior…anyway, I have to agree with Sam, it sounds more like kodi than a Vero issue.

Ok, guys…

Got to the bottom of the problem. Some screensaver setting was off here, so that the “black” screensaver internally got activated after the 1 minute I have set, but didn’t show. So, the screen stayed bright. Obviously, because of this, the screensaver got deactivated with the first button press, but I thought it never got activated in the first place due to it not being visible…

Now, I re-entered my preferred screensaver settings and everything’s back to how I’d expect it to be. With screensaver switched on, the screen turns black no matter what (except during playback) and I obviously need a first button press to stop the screensaver…
With the screensaver set to off, there’s never a need for a first “wakeup” button press (not after 3 minutes, never).

I’m sorry, Sam, but a wakeup button press with no screensaver being active is not normal, it’s only normal, if the screensaver kicks in. :wink:

Got it fixed for me now, sorry to bother you guys… Thread can be closed :+1:

Yeah I was just about to say that, it sounds like the expectated screen saver behavior… the first things I do on every Kodi is to disable all kind of screen savers and standbys, so I do NOT have the behavior you described… just tested it and I have no issue.

It is not always easy to realize if it is an Kodi or a Vero issue since the Vero only runs Kodi. I know it is sometimes frustrating for Sam to answer Kodi related questions.

I understand that… Wasn’t sure myself what it was. Obviously it was simply a setting not doing what it was supposed to do - don’t ask me why: the screensaver was active, but simply wasn’t showing when pausing a playback. So, the second press needed seemed completely off for me :joy:
It was just a bug here…