Vero 4k & OSMC & USB Hub problems

Hi there,
Due to power problems with Vero I had OSMC TV stick pluged in dicretily to a RPI 2 usb port and I got TV signal from net, now I have purchased a usb-hub.

If I shutdown the system, plug in the stick and boot it, the stick is recongised and I can access to TV channels.

osmc@pi2:/$ lsmod | grep dvb
dvb_usb_rtl28xxu 36864 1
dvb_usb_v2 24576 1 dvb_usb_rtl28xxu
dvb_core 126976 3 cxd2841er,dvb_usb_v2,rtl2832
videobuf2_vmalloc 16384 2 dvb_core,bcm2835_v4l2
rc_core 49152 4 dvb_usb_v2,dvb_usb_rtl28xxu
videobuf2_common 53248 5 bcm2835_codec,dvb_core,bcm2835_v4l2,v4l2_mem2mem,videobuf2_v4l2

But when it change to sleep mode or I reboot, nor Vero nor Rpi load the driver correctly and Kodi saids “No free device avaliable”

osmc@pi2:/lib/modules/4.19.122-1-osmc/kernel/drivers/media$ lsmod |grep dvb
dvb_usb_rtl28xxu 36864 0
dvb_usb_v2 24576 1 dvb_usb_rtl28xxu
dvb_core 126976 2 dvb_usb_v2,rtl2832
videobuf2_vmalloc 16384 2 dvb_core,bcm2835_v4l2
videobuf2_common 53248 5 bcm2835_codec,dvb_core,bcm2835_v4l2,v4l2_mem2mem,videobuf2_v4l2

I have being googling and it might be a problem when the system unload the drivers, I don’t know.

Thanks in advace.

Hi this problem is probably connected with usb hub backfeeding. In other words dvbt2 dongle is still under power during a reboot and it makes the dongle unusable for system. I found a partialy solution with cutting +5v wire between vero and the hub. But it causes another probs with detecting devices connected to the hub by VERO. Maybe it could help if usb ports go on/off during every reboot of the system.

Did you purchase an OSMC hub?


Sorry I haven’t be able to answer before and thanks for reply.

Vero did extranges things with hub & dvb, some times it hanged or it didn´t recoginese the dvb device at boot.

Since I could reboot Vero with the stick pluged (disconeting de device during the reboot), every thing works fine.

I bought in a local shop and isn´t OSMC’s one, it might be the main problem.

Thanks again.

The tuners might not be getting enough power from the hub. Could also be as simple as a bad USB cable.

Sam, i´ve got osmc hub. I tried connect dc adapter and it’s the same. USB hub powers VERO. If i disconnect power from VERO, VERO stays on. After reboot from menu, dvbt dongle says no free adapter. Is there any chance for solution without cutting +5V line between VERO and HUB?


What makes you think that the issue so caused by the hub?


I tried this combination just vero, osmc powered hub, osmc dvbt dongle and osmc remote dongle. When i boot to KODI and then disconnect power from VERO. It stays ON, powered from usb hub.

Second thing is problem with dvbt dongle, after reboot is still powered via usb and KODI says no free adapters.

That’s fine - the hub can be used to power the device.

For the no free adapter issue we can implement USB reset in 4.9.

Ok if backfeed is not problem for VERO.
USB reset will help much. I am in 4.9 testing group, look forward for implementation.
Best regards Lance