Vero 4k output

Having some issues with 10 bit 4k files on my panasonic 4k TV
Picture is Dark and doesnt seem true 4k.
Files are all 10bit. No issue with HDMI cable

here is output while playback is happening. Not sure why EOTF is displaying SDR? could this be issue

root@osmc:/home/osmc# cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

Any suggestions welcome.

I should add auto refresh is enabled. playback sync to display is disabled.

Can you please paste some full logs?


whats quickest way to do that. sorry im a linux novice

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

ok thanks for that. logs available here:

Do you have HDR turned on on the TV? Setup->HDMI HDR on.

Ya ive reviewed all tv settings. Mode 2 is selected for hdmi

Is there an AVR in between?

Nope connected directly

Okay. Your TV isn’t advertising support for HDR, which is why things don’t look very good. I suspect it’s a setting that needs to be changed on the TV

Hmmm ok. Its a panasonic 40dx600b

seems that while it accepts HDR content it doesnt support it.

I’m not sure what that means.
We do have an option coming to force HDR and this will be available shortly; so might do the trick for you.

It’s not in those settings. My 40EX700B has a separate HDR setting