VERO 4K + PKC : Long launching time for videos


I am scratching my overhead the following, and may be some of you have information or solutions to propose. I am not sure this is VERO related or PKC.

My Current Set Up :

  • Server side :

o NAS Synology DS218+ with DSM version 6.2.2-24922, 16To JBOD and 6Go Ram, Plex Media Server on NAS, version Drives are set up as to never go to sleep. AFB and NFS sharing is activated. I have been using a NAS for 2 months as first time user, so I’m a pure freshmen on network / sharing configuration.

  • Reader side :

o VERO 4K+ connected with the NAS through a Switch and gigabit Ethernet. The VERO is connected on TV through HDMI. I am using PlexKodiConnect (version 2.8.7) with Kodi Leia on the Vero. When installing PKC, I had to manually input the IP address of the media server in PKC, the auto detection wasn’t working. I am using Night Skin in Kodi from bkury (link). I am not really sure which sharing service the VERO is using to access the NAS (for example when I deactivate NFS an AFP and activate SMB, Vero is still playing movies without any restart of PKC and OSMC, so I am not sure these type of sharing are even used by VERO with PKC, probably something through http/ftp with Plex Server?). PKC is set up as Default Addon path.

o Mac Mini 2018 (Core i5 3Ghz 8Go Ram) connected through Wifi, with Kodi Leia and PKC (same version as VERO)

o When watching videos, I never transcode content, I go for direct play every time. This is easy as 99% of the time, I watch on TV+VERO.

  • Network : I have my router (box from provider) connected to internet, a Google Wifi connected to the router and a switch connected to the google WiFi, so all devices are connected on my google box through wifi or switch. (I had to add a Google Wifi as the router provided by my internet provider has bad and instable wifi connectivity).

My issues :

  1. On the Vero : Launching movies/tv shows (whatever the size or format : 4K HDR 265, 720p SDR) might take up to 30 seconds to launch, the spinning wheel starts, then stops and restart again and then the movie starts. The playback has no issue at all, my concern is only around the launch time. This launch behavior isn’t happening all the time, sometimes it starts immediately but most of the time is doesn’t.
  • Long loading time Log example 1 : (, I tried to launch Avengers End Game movie around : 2019-08-22 22:18:24

  • Long loading time Log example 2 : ([](http://)), launching a 720p tv show Ballers s01e01 at around 2019-08-22 22:32:17

  • No loading time : After the second log without restarting the Vero I tried launching Avengers again, it gave me an error message but movie launched anyway after several seconds. I stopped and tried launching Captain Marvel, it launched immediately ([](http://)) at around 22:39:23 (big log sorry)

  • No loading time on Mac mini over wifi : (

  1. On Deck Widget from Plex : very slow to load : 20-30 seconds, and when I finish an episode, the On Deck doesn’t get updated until an unknown time

So as you can see, things are working but there are some time delays involved, the thing that make me believe I have an issue is the following : when I use my Mac Mini (over wifi) with same set up as VERO (Kodi 18.3, PKC, same skin), none of the above exists, movies (even 60Go file) are launched immediately, On Deck Widget is immediate and works smoothly.

I am unable to tell if these behaviors are coming from the Vero, PKC, the Skin, the network or a combination of those.

I tried providing as much log as possible, your help is greatly appreciated

Thank you

I’ve not played with it and don’t know enough to want to air my thoughts but I did notice this…

Vero: v2.8.7 installed
Apple: v2.9.3 installed

and this on both…

PLEX.service: PKC Direct Paths: False

which would go to a question you raised about your shares. You probably would want to read this.

Can you try the official Plex add-on as a test and see if that behaves?


OK will try Plex add on tonight.

I am not using Direct Path, however your link indicates that add on path should start in 5 sec. I am more around 20-30 seconds and not all the time.
But I will probably have to give a shot at Direct path to see if it works faster

I own a Syno DS214se …but this very sounds like your NAS and/or the used drives in the NAS were hibernated on the first try and were online and responsive on every continuing try after that.
Have you checked your Syno logs for this?

Official plex add on is abandoned already. Not working on Vero. Hasn’t been updated since kodi 17.

Not sure if this can help.

In the logs that I scanned through I saw what looked like a lot of repeated attempts to pull the stream over the internet. It made me think that perhaps something in your network was blocking whatever local discovery communication it uses to automatically find the server on your LAN. From a quick scan of the docs it looked like you could just point the client in the settings to where your files where which would work around any local discovery packet blocking. It is a frequent issues with other devices that rely on broadcast traffic like airplay.


Thank you for these sets of comments. I try to go through one by one.

Direct Path : I will probably have to try activating Direct Path when I find 1-2 free hours to do it. Will let you know.

Official Addon isn’t working as advised.

I confirm the Synology is set as to never go to hibernation. After checking the logs, there is no hibernation or sleep activity from the drives. Anyway the long loading time happens most of the time and not only on first movie launch.

This above is interesting, the NAS is connected over internet through a VPN, but I wouldn’t expect this to impact the local network? I will try to disconnect the VPN to eliminate this.
What do you mean by “you could just point the client in the settings to where your files where which would work around any local discovery packet blocking”, where should I go to do this? I do not point Kodi anywhere, I connect Kodi on the Plex Server with PKC.

Thank you

If you look in the logs from the Mac you can see

PLEX.initialsetup: Using PMS with machineIdentifier 480e19a9da51a34f2ba436fa6f3defe42dc09917

which shows it is able to talk to your NAS over the LAN and that would imply that the VPN is not an issue here. It is also showing that it is able to establish whatever communication it needs to directly transfer the files over the LAN.

On your Vero however you can see

PLEX.initialsetup: Using PMS with machineIdentifier 480e19a9da51a34f2ba436fa6f3defe42dc09917

which appears to show that the Vero can see the server on the LAN as well but for whatever reason is not able to access the files that way.

I think the first thing to do is update the plugin so it is running the same version as your Mac. If that doesn’t work then try to setup that direct play manually.