Vero 4K+ Playback failed on newly added or moved video files

Hello, I have been using Vero 4K+ since 2021 with NFS file sources (autofs) pointing to my QNAP NAS without any issues. Over Christmas I’d upgraded to “2023.12-1” and then noticed I started getting the “Play Back Failed” error (“One or more items failed to Play. Check the log for more information…”) on any new videos that I’ve added or moved to another folder within my NAS.

To try fixing the problem, I’ve removed and re-added my file sources from Vero 4k+, downgraded my Vero 4K+ to “2023.08-1” but I am still getting the same error. I have Enabled debug logging and have generated and uploaded the log “”.

In the log, you can see I’ve tried to access 2 videos:

  1. Matt’s 21st - Test.mp4
  2. Matt’s 21st - Test-NFS.mp4

Video 2 is an exact copy of video 1, but renamed with “-NFS” suffix, but video 1 plays correct while video 2 does not.

The Playback failed error is not restricted to MP4, but also with MKV and Avi files. The only pattern that I can [pick out is that this only happens with new files that I have either added to my NAS, copied from one folder to another or renamed.

Also, to take config on the NAS out of the equation. I have mapped a drive on my Windows PC to my NAS and I can play the videos from my Windows PC using VLC media player without any issues.

Any help you can provide will be much appreciated!

What is the output of
ls -lah /mnt/Multimedia
ls -lah "/mnt/Multimedia/1. My Movies/1.4 Temp/Matt's 21st - Test-NFS.mp4"

ls -lah /mnt/Multimedia:

osmc@osmc:~$ ls -lah /mnt/Multimedia
total 6.8M
drwxrwxrwx 22 root users 4.0K Jan 16 22:07 .
drwxr-xr-x 3 root root 4.0K Jan 16 20:50 …
drwxrwxrwx 10 root users 4.0K Oct 3 2021 .@__thumb
drwxrwx— 2 root users 4.0K Apr 21 2023 .AppleDB
-rwxrwx— 1 root root 8.1K Apr 21 2023 .DS_Store
drwxrwxrwx 34 root users 4.0K May 23 2021 .streams
drwxrwxrwx 9 root users 4.0K Jan 16 22:08 ‘1. My Movies’
drwxrwx— 5 root users 4.0K Jun 4 2020 ‘2. My TV Serials - Parents’
drwxrwx— 18 500 users 4.0K Dec 27 09:52 ‘3. My TV Serials - Family’
drwxrwx— 29 root users 4.0K Apr 24 2022 ‘4. My Lifestyle - Documentaries’
drwxrwx— 25 root users 4.0K Apr 24 2022 ‘5. My Musicals, Music Videos’
drwxrwx— 5 root users 4.0K Jan 7 2022 ‘6. My Sports’
drwxrwx— 34 root users 4.0K Nov 30 2021 ‘7. My Educational Videos’
drwxrwx— 28 root users 4.0K May 3 2022 ‘8. My Family-Home Videos’
drwxrwxrwx 6 root users 4.0K Jan 12 04:03 @Recycle
-rwxrwx— 1 500 users 3.0M Oct 3 2021 ‘Happy Birthday Hugh.mp4’
drwxrwx— 11 root users 4.0K Nov 5 2022 ‘My Audio Books’
drwxrwx— 37 root users 4.0K May 22 2023 ‘My Photos’
drwxrwx— 115 root users 12K Dec 28 11:12 MyMusic
-rwxrwx— 1 root users 3.4M Jul 19 2019 ‘New’
drwxrwx— 28 root users 4.0K Nov 19 2021 ‘Zoom Virtual Backgrounds’
drwxrwx— 2 506 users 12K May 17 2019 dan21
drwxrwx— 3 506 users 4.0K May 18 2019 dan21party
-rwxrwx— 1 500 users 244K Sep 24 2016 folder.jpeg
-rwxrwx— 1 root root 59K Aug 19 2021 folder.jpg
drwxrwx— 4 root root 4.0K Apr 11 2022 marsh
drwxr-x— 2 501 users 4.0K Jan 16 20:22 'osmc_backup ’

ls -lah “/mnt/Multimedia/1. My Movies/1.4 Temp/Matt’s 21st - Test-NFS.mp4”:

osmc@osmc:~$ ls -lah “/mnt/Multimedia/1. My Movies/1.4 Temp/Matt’s 21st - Test-NFS.mp4”
-rwxrwx— 1 root root 41M Dec 5 2018 “/mnt/Multimedia/1. My Movies/1.4 Temp/Matt’s 21st - Test-NFS.mp4”

Thanks for getting me to check the permissions. I can see I’ve inadvertently connected from my PC to my NAS using my “admin” account and all new files were added as admin in the root group, hence Vero was not able to read the file (doh).

I have changed the ownership and group membership of all of the files with the admin/root back to what it should be and all is working now