Vero 4k+ Playback Issues

Hi, after running my Vero 4k+ on Kodi 18.9 until last month I finally decided to upgrade to 19.3, following the upgrade I started having playback issues with multiple files, in each instance the audio was fine but the video was either black or lurched between stills approximately 5 seconds apart. At the time I gave up and rolled back to 18.9 where all was once again good. Yesterday I tried again with the 19.4 March release and am experiencing the same issues. The Vero is connected via a Sony AVR but fault exists when connected directly to the TV which is an LG 756Nano series, 4.2.2. pulldown is enabled in Kodi as per recommendation for LG TVs.

Link to log file (generated whilst trying to play a file which stutters)

Media info for file which stutters:

Media info for file with black screen:

The same files play flawlessly when the Vero is replaced by my Pi4 Media Player running the same version of OSMC.

The fault occurs with all UHD/4k content i’ve tried and some 1080p (can’t locate an example at the minute)

After years of rock solid performance this is driving me insane now and just want to get back to it working without having to downgrade again


1 Like

Good to know that this issue still exists after the latest update.
I think it’s the same one as reported here:

The changelog didn’t mention anything specific to this issue except for this:

In the background, we’re laying the groundwork for a number of other changes which will be released in the near future, including improvements to video playback for Vero 4K/4K+

So there is still hope.

In the meantime, cold rebooting helps.

Thanks, interesting read! Unfortunately cold or warm rebooting doesn’t make any difference, I have 100% failure rate with these files playing back. What I didn’t see on the other thread was any reference to no video at all, just stuttering.

I’ve sent you some details with a possible solution.

Thanks, the suggested temp solution works as expected

Thanks for confirming Chris.

I am also seeing this behaviour, although it’s only dropped frames. Is a reinstall of the OSMC then suggested remedy?

After updating to 19.4, the video started to stutter. Before the update everything was fine. I fixed the problem by disabling HW acceleration. The details of the video I’m watching the problem with are:

Complete name                  : Z:\Serie\Policie Chicago\Policie Chicago S02E23 TVRip 720p CZdab.avi
Format                         : AVI
Format/Info                    : Audio Video Interleave
File size                      : 486 MiB
Duration                       : 40 min 16 s
Overall bit rate               : 1 689 kb/s

ID                             : 0
Format                         : AVC
Format/Info                    : Advanced Video Codec
Format profile                 : High@L3.1
Format settings                : CABAC / 4 Ref Frames
Format settings, CABAC         : Yes
Format settings, Reference fra : 4 frames
Codec ID                       : H264
Duration                       : 40 min 16 s
Bit rate                       : 1 500 kb/s
Width                          : 1 280 pixels
Height                         : 720 pixels
Display aspect ratio           : 16:9
Frame rate                     : 25.000 FPS
Color space                    : YUV
Chroma subsampling             : 4:2:0
Bit depth                      : 8 bits
Scan type                      : Progressive
Bits/(Pixel*Frame)             : 0.065
Stream size                    : 428 MiB (88%)
Writing library                : x264 core 155
Encoding settings              : cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=2 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=22 / lookahead_threads=5 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=10 / rc=abr / mbtree=1 / bitrate=1500 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00

ID                             : 1
Format                         : AC-3
Format/Info                    : Audio Coding 3
Commercial name                : Dolby Digital
Codec ID                       : 2000
Duration                       : 40 min 16 s
Bit rate mode                  : Constant
Bit rate                       : 192 kb/s
Channel(s)                     : 2 channels
Channel layout                 : L R
Sampling rate                  : 48.0 kHz
Frame rate                     : 31.250 FPS (1536 SPF)
Bit depth                      : 16 bits
Compression mode               : Lossy
Stream size                    : 55.3 MiB (11%)
Alignment                      : Aligned on interleaves
Interleave, duration           : 32  ms (0.80 video frame)
Service kind                   : Complete Main

There is no problem with other videos.

can you or Sam explain what the suggested solution is exactly ?
Thanks in advance, current HEVC stutterring is really a pain …

There’s a non-standard SD/USB image to run from until the issue is fixed in the normal release, Sam need to add you to the group to access though

Thank you for the answer, that is a good news that a fix exists already and coming !

@sam_nazarko, I’ll leave to you to include me in the test if this can help!

Otherwise I will just wait for the next official release, hopefully it comes very soon