Vero 4k+ Power Cuts Out. Repeatedly. Randomly

Just received the Vero 4k+ this morning and started setting it up with my library. The power then promptly cut out. It did not reboot. It just “switched” off. I have not bothered to SSH into it at this point, because I cannot get it to stay connected to a wireless network as it needs to be reentered and reconfigured every time it starts up. The power usually dies before I can get it configured.

I was able to perform one update from 2019 Nov to 2020 June before it crashed again. Is the Vero image on the website compatible with the 4k+? That is about the limit of what I am willing to do to the unit.

And just to aggravate me just that much more with a unit that was delivered about three hours ago, the battery in the remote is about dead.


I’m sorry to hear you’ve experienced a problem.
The Vero 4K / 4K + images from the website can be used to reinstall OSMC on the device.

How have you determined that the device is losing power?
Does the front LED on the device turn red? Does the red LED on the optical port stay illuminated?

Could you clarify how you have determined that the battery is dead?

We’ll get this solved for you promptly.



Hello Sam,

Thank you for the quick response. I just wanted to confirm that the Vero image on the website applied to the 4k+ before I tried it and bricked the device.

As far as the loss of power, at first I just assumed it was just the HDMI signal cutting out. After a couple times and trying SSH, I checked the USBs for power and optical out and found neither were powered.

The LED on the device is red only during the boot of the device and then is no longer lit. Update on that - the LED is no longer lighting up when the device is powered up. When the device “boots” everything appears quite corrupted and almost instantly freezes. Preparing to install the new image now.

I’ll throw a meter on the battery, but one of few things the Vero did successfully was point out the battery in the remote is low. I’m pretty sure I have a pack or two of CR2032s laying around somewhere.


You won’t be able to brick the device by using the wrong image. The device simply won’t boot. Make sure you use the ones listed as Vero 4K / 4K + and not Vero or Vero 2.

Feel free to upload a screenshot of the contents of the SD card or USB stick so we can confirm that it is imaged properly.

This is the expected functionality of the device.

Might be a false reading, try re-seat the battery and hold Home and OK for a few seconds to force the remote to re-pair with the receiver.


Hello again Sam,

After reimaging the device, setup proceeded along smoothly until I began adding media libraries. It started cataloging the movies and then the power cut for the first time on the new image. And it just happened again as I type this while updating the library. When the device was repowered, no red LED was turned on. Just for fun, I rebooted the device via the power menu and the red LED turned up during the boot.

Thank you.

EDIT - power cut again while downloading Nov update. No LED on repower after power cut. Power cut again after almost exactly five minutes from initial repower. This includes the successful update reboot approximately 2 min 30 sec prior to power cut.

EDIT 2 - Disconnected both HDMI and power prior to rebooting. Red LED on during initialization. Power cut two two minutes after reboot (within a few seconds).

EDIT 3 - The power consistently cuts out on the unit between two to three minutes.

It’s the best two minute media center ever! (j/k - couldn’t resist) I did manage to upload the logs prior to the end of my most recent two minute window.

Thanks. Can you confirm what peripherals are attached to the device?


Of course!

Samsung C24F290 monitor
Vero Power Supply
Vero Remote USB Dongle


That’s fine. I had wondered if you had something like a hard drive attached.

The hardware would’ve been tested prior to dispatch, so I suspect your issue may be the power supply.

Can you let me know your order number and confirm your address is the same so I can post you one tomorrow?

I’d then suggest connecting the new power supply and performing a final reinstall just in case your system has some corruption due to the power issues.


Hello Sam,

My order number is as follows: Order #31334 ( November 23, 2020 )

I haven’t had a chance to check as to whether or not I have another 5V2A PS. I may be able to look in a few hours.

Thank you again.

Thanks. I’ll get this out for you now



Just a quick update. Attempted using a 5V3A PS, which appears to work a tiny bit better. It took a little while for the power to die the first time. It was a fresh installation as well. Since then, the time to power out is diminishing.

Also, I am unable to connect or stay connected to a 5G wifi. This leads to believe it is a power issue, although I’m concerned about the chances of two bad PS.

I would not recommend using another power supply that has not been designed for the device.
You could try powering the device via USB cable from a laptop or PC.

The device did not boot successfully via USB A to USB A but did successfully scramble the SD with the new image. The “Power Supply” is a Dell Dock with a USB A to DC Plug Connector.

What do you mean by scramble the SD?

The SD Card was corrupted during installation. The same thing with an installation yesterday with the original power supply. I haven’t bothered to recover them yet - I’ll leave that for another day.

Does the device have a “trip” feature if the power is inadequate? Most of the power drops were during active network use while updating/creating media libraries?

Update - received the new PS this morning. To this point, two clean installations have been completed and multiple power failures have occurred.

After the first installation, visual artifacts would occur in the OSMC background image, and some artifacts would appear around the text. Attempted to sync libraries and configure PVR. It would only perform a partial library scan (approximately 70% of the library) before completing. Was in the movie directory when the power clipped the first time.

The second installation on a different SD card and with a fresh image also has artifacts. After installation, started configuration of the PVR, which was successful. Next, added file locations via the File Manager and was preparing to start adding media libraries when the power clipped. I was in the menu configuring the media database at the moment it happened - it had not started to scrape the files.

I would suggest contacting with your order details so we can look at this in more detail.

Thank you Sam.

Email sent with order reference and logs.

Thanks. I’ll give this a response shortly.