Vero 4K - problems and then reset


I was trying to connect to a drive that is connected to my Vero - to transfer some files, by following the instructions here: External usb drive mount - #2 by yknivag

In short, I wanted to be able to transfer a file from my laptop (Mac) via finder to the Vero attached drive.

I failed…

So now I have a host of errors when I switch the TV input to the Vero input. So I am trying to reset it.

I have the installer - I go through the questions, and have now tried 2 USB sticks - but I get the message - an error occurred while writing the image. 1st stick was 4gb, the 2nd is 16gb.

Is there another way to reset?
And how do I add the attached drive as a share so that I can transfer to it?
I did transfer the file via finder to the Video folder of the Vero - but this didn’t show up on the device itself when I browsed that folder via the TV.


I believe that MacOS has the scp command, so you could run this from the command line:

scp <file name> osmc@<vero4K-IP-address>:<destination-folder>

You’ll need to fill in the details inside the <> symbols. (Note the : in the command.)

External drives should be automatically mounted. If that is not the case suggest to provide logs so that we can check.

Assuming you are running the installer on MacOS, there might be problems. Suggest to just write the image to USB with e.g. Etcher.

When your Vero is reinstalled and working you can install Samba Server on Vero from App Store that allows to transfer files via finder.

Yes, if you still can connect to the device via SSH or you can connect a keyboard and go to command line you could follow these instructions:

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2


I tried the mv ~/.kodi ~/kodi.bak but I get the message

/root/.kodi: no such a file or directory

I connected via a keyboard


You must be logged in as user osmc, not the root user.

Doesn’t the osmc hash indicate that?

Nope that is the device name unless it is osmc@osmc but you are either logged in as root or executed su.
Anyway either go back to osmc user or run mv /home/osmc/.kodi /home/osmc/kodi.bak

Tried that, but the message back is that the system is booting up and unprivileged users are not permitted to log in yet

That sounds strange, I really wonder what you might have done to your setup.
Might really the best to do a full reinstall via USB stick.

1 Like

Okay thanks. Did that and back to normal.

However - same problem exists with not being able to see the mounted drives when connecting via Finder.

I can’t see the mounted drives in Finder - but can see them in the browser interface.

Could you ssh to the vero and provide the urls from the following cmd:

for f in /etc/samba/smb*; do paste-log $f; done

You auto mounted drives look strange, how are they formatted? Maybe makes sense to give them a proper label to make them recognizable.

Also to reconfirm you installed Samba Server via MyOSMC Appstore?