Vero 4K rebuild - Latest Build

My Vero 4K was another device which wouldn’t update to the August release. Same issue as others with the connectivity issue message. I tried manually updating via Putty but whilst this kicked it off, the update still failed :frowning: .

Anyway in the end I rebuilt my Vero 4k from scratch using the latest image and the OSMC installer tool.

I chose the August build, and it worked fine. I noticed however if I run the update afterwards (expecting to tell me I have the latest version) it still updates a small number of files.

Is the August build on the install page an earlier version that needs an additional small update to bring up to the latest version?


Stange, how come? Are the builds not the final stable version?

Having worked in software development I can safely say there’s no such thing as a “final stable version” of anything. You test software, and you spot and fix all the bugs you can find; but once it goes out to users who are doing things with it that you didn’t anticipate, more bugs inevitably surface. And even when you’ve fixed those, new users come along who expose new bugs, and so on, ad infinitum.

1 Like

Shouldn’t be the case – unless you have a development repository enabled or checked for updates manually which will grab upstream Debian updates (not part of the OSMC release).

You could have just entered the hotfix code via My OSMC as advised.


Hi Sam,

Thanks for replying.

The dev repository wasn’t enabled. I simply rebuilt the device, went straight into My OSMC, ran the update (as I was curious to confirm I was on the latest public release), and the additional files were updated.

I’ve rebuilt again this morning from scratch and it was exactly the same.

Not an issue, I was more letting you know incase there was a slight difference in the build image and the update process that you weren’t aware of.

Happy to do it again and take screen shots if it helps, as I have 2 Vero 4k’s so not a problem my side.

Then you triggered a manual update – which will download Debian (not necessarily) OSMC updates.

This isn’t an issue and is expected behaviour. Your system was already up to date when you reimaged with the latest OSMC packages installed.