Vero 4k recovery error - Hardware faulty

Hi guys,

I got a Vero 4K last week and on the first day it broke. It got corrupted somehow and I had to reinstall. I fired it up when I got it but had to work so shut it down, after booting up later in the day I saw the following…

“Waiting for root filesystem device/dev/vero-nand/root 'Fatal Error: could not find root filesystem device/dev/vero-nand/root- if this is USB install please check USB drive is connected OSMC Initramfs Rescue Console For help and support see https:// OSMC.tv/ 3”

So, a bit miffed, I came to the support forums and I followed this article… Reinstalling OSMC - Vero 4K - OSMC

I created the SD Card image ( i had to use Win32 disk imager because the osmc-installer kept failing when writing to the SDCard. It just said Error occurred: Check the logs but I dont know where there logs are) I then held in the reset button and booted from the SD Card and now I see the following… “Install failed. Please contact support. Hardware faulty” Can you tell me what to do next?

I also tried a different SD Card and finally a USB stick. I used the image called… OSMC_TGT_vero3_20180609.img

Sam said he was travelling so I burned an copy of LibreELEC to an SD card and have been using that since fine but I would like to find a solution to be able to install OSMC again.

Thanks

@sam_nazarko FYI I logged this issue on the 12th July Ticket no. #381995

Hi

Sorry to hear you’ve had a problem with the device.

I will update the ticket and it will likely need to be sent back to us.

Some versions of LibreELEC can corrupt the internal firmware on the device by automounting partitions. This is why you will not be able to reinstall OSMC.

Sam

Edit: I’ve now updated the ticket with some instructions that may help.

@sam_nazarko So is the issue simply a partition problem? I did install LibreELEC to the internal emmc because I needed the sd card so it would have formatted that. Do you have a image of OSMC that will run from an SD Card itself and can then be reinstalled to the internal memory via SSH?

Hi

If you install LibreELEC to the internal storage the device can become damaged. I don’t believe there’s any official LibreELEC devices supported apart from ODroid C2 and some WeTek units. So I’m not sure which Device Tree or image you used.

That’s the idea behind images from osmc.tv/download, but they may not work if the internal partitioning structure has been changed significantly, hence why your device is telling you to contact support.

This happened with another user and we had to get the unit returned for us to remedy the situation.

Sam

Ok. I am using LibreELEC 8.2.4.2 with the S905X device tree gxl_p212_2g. It runs perfectly and even better in some ways. I have a Wetek Hub (S905H) which has no HDR so the first thing I tried when I got the Vero was mapping an NFS share to my NAS and playing some 4K HDR with TrueHD and DTS-HD MA test files through my Onkyo HD receiver. Primarily I wanted to make sure it would trigger the HDR on my TV, which it did, but I noticed there was no sound. No matter what settings I chose I could not get it to work. After numerous tests I found it was not necessarily the HD sound but the number of channels. DTS/HD 5.1 worked in OSMC but no 7.1 track would produce sound. When I installed LE 8.2.4.2 I found this was fixed and the HDR triggered and the HD audio (regardless of channels) passed through to the receiver as expected.

Back to the issue though. That sounds like a lot of unnecessary extra work for you, and customers, having to send a device back to you just to reimage the emmc. If the recovery sd card cant simply wipe the internal storage and re partition it like a factory reset? Is it possible to use the male to male usb cable with a PC to image it that way?
I’ve been using ELEC images on Amlogic devices for a few years and never heard of a device being damaged, so to speak, to a point where it had to be returned jsut from installing an OS. If there is no other solution than returning it then I’ll just stick with what works on it, which is a shame as I paid a large premium (€140 from ModMyPi vs €50 for the average S905X box) thinking the Vero 4K was something well built and solid. Sorry if that sounds whiny, I know you put a lot of effort into it, but I just wanted an S905X to play HDR and HD Audio passthrough and the Vero 4K didnt do that and then broke itself. ( I know I helped it break :blush: but its not physically damaged so shouldnt need to be returned )

Btw something must have happened before I installed LE as I was getting the error about faulty hardware as soon as I tried the repair after it failed to load. I logged the ticket and then later installed LE so the issue was pre-existing and not from installing LE to the internal memory.

Hi

I don’t think there is an official LE 8.2.4.2 release for AMLogic devices, so I suspect you are running a community build.

The cause of this issue was identified a couple of days ago and will be fixed in the next update. It was caused by a fix introduced for USB audio in the June update. In the interim: you can select ‘PCM’ audio and it will work fine. This issue will only present if you do not use passthrough.

There is already a procedure to re-install OSMC on the device, and it works reliably. However if the structure of the eMMC is changed (different DTB), then things become more complicated, particularly as we do not track the changes other operating systems make.

I have sent you some detailed instructions via the ticket.

The main difference between a generic AML box and ours is support and build quality. The device comes with five years of long term support, which means that over a period of time the Vero 4K is likely to be more affordable than other devices.

HD audio passthrough and HDR should be working fine on OSMC on Vero 4K. When you get OSMC back on your device, we can revisit those issues for you in a separate topic. I’ve checked tickets and forum posts and can’t find any support requests regarding this; or we’d have helped you by now.

Please try the instructions forwarded to you and let me know how you get on at your earliest convenience.

Thanks for your understanding

Sam

I’ve just checked and it looks like you’re using a wrxtasy build.

They are using our latest HD audio improvements so the behaviour should be exactly the same, i.e. if it works on LE it will work on OSMC.

Sam,

My father just purchased a vero 4k+ and they day he got it, he plugged it in and it comes up as X90 box. I tried reinstalling OSMC, but it crashes with the “Hardware is Faulty Contact Support.” I have tried a couple of flash drives to no avail. This baby was as new as it could be. Any suggestions short of sending it back across the pond? Seems like it functions as X90 properly. It’s like it’s not seeing the internal flash to re-write.

Thanks

Seems quite odd. Please contact support@osmc.tv

Sam