Vero 4k Red Light not detected in windows device manager

I purchased a Vero 4k in June 2018, it has been working flawlessly up until very recently. Now when plugged in with the official PSU supplied with the Vero 4k all I see is a black picture and a constant red led light.

I have tried powering the Vero 4k via the white USB port using just a USB cable plugged into my PC. I still just have the same red LED. Device Manager is not picking up any new devices. I have tried flashing an SD card with the latest firmware but the device is not event booting to a screen of any sorts.

Is there anything I can do to return my Vero 4k back to life? I would be happy to try anything apart from taking a soldering iron to it :rofl:

Many thanks,
Sam

Have you tried a new PSU ?

Are you sure the PC USB port can supply the required current ?

(The PSU specs are: 5V, 2A center positive, 5.5mm OD; 2.1mm ID - although I would personally recommend 3A)
e.g. 5V 3A Mains Adapter 2.1mm DC PSU 12.5W UK Power Supply [006027] 5055383460274 | eBay

Good point, I have tried power the Vero 4k with an Anker phone charger which supplies 5v 2.4A and still no sign of life. I can buy another charger, is there anything else I could try?

Chargers aren’t the same as power supplies and aren’t designed to supply constant load.

Thanks Sam, I purchased another Vero 4K for my parents so I’ll pay them a visit next week and do some testing with their PSU. Fingers crossed!

1 Like