Vero 4K Red Light

Hello, I’m getting the red light on my Vero 4K. I didn’t see a serial number on the unit, only a MAC address.

I’ve tried using the USB port to power it up like suggested in the forums. This doesn’t work for me. I’m either but doing something correctly, it there is a different problem.

I didn’t have a USB A to A cable, but I did try a USB C to A cable which I would think should work. I tried in plugged into both USB ports, both the white and the black one.

I’d like to fix this one if I could. I’d recently bought the best one and was planning on migrating it over and then gifting this one. I’d still like to be able to do that.

This unfortunately will not work. You would need a USB A-A cable.

Do you have the Vero V already? then you could use the Vero V power supply to test if the Vero4k is still alive. After that is confirmed then just get a new power supply.

I tried the C to A because I thought I’d read in a thread that it worked. Guess it doesn’t.

I do have the Vero V and I plugged its power cord into my Vero 4K. Initially, it lit up red but after a few seconds it turned blue. So I think we know the culprit.

How do I get a replacement?

You can either get a replacement from your local store (check specs in detail)

5V, 2A center positive, 5.5mm OD, 2.1mm ID

Or use one of this order links


Thank you for all the help, much appreciated.