Vero 4k remote control battery contacts


Has anyone else had problems with the battery connection in their Vero 4k remote?

Recently my remote is randomly non-responsive; when this occurs the blue led does not light when any buttons are operated, and the vero does not react to input.

I’ve changed the cr2032 cell, however the issue remains.

Any suggestions gratefully received…

Hi RR,

I thought we sent you a new one recently?
It’d be odd but obviously possible to experience issues with another remote.

Haven’t had any complaints with the remotes from the batch I sent you.

Can you show me a picture of how the battery is seated?




You did indeed, which is why I asked if anyone else had a similar issue, as two failures seems odd (and I am very careful with all electronics).

I’ll post a picture soon (although the battery tends to move or become ejected without the cover in place).

For the time being I’ve gently adjusted the contact points to see if this helps.


Is this a new cell?
I’ve noticed with some returns we got (almost always just a bad battery) that some cells are swelling.

Hi Sam,

The remote was non-responsive again just now (I’ve just woken up, thanks to insomnia…)

I’ve just tried 5 different cr2032 cells, all previously unused, but of unknown vintage. Two are Sony, the rest unbranded.

Of these, one allowed the led to show normally, one which briefly, weakly showed the led. None of the others worked.

On a voltmeter, one cell registered only 0.25v, so was evidently dead.

Two registered 4.33 volts, but do not allow the remote to work. One showed 4.55 volts. All are marked as 3v cells, however these readings are taken without load.

Is the remote particularly sensitive to the cell’s output voltage?

I’ve been trying to source genuine sony or duracell batteries from amazon, however the reviews suggest it’s a lottery as cheap knockoffs are rife, even if Amazon itself, rather than a third party, is the seller.

Not sure if where the issue is now. Batteries registering 4.33 or more volts don’t appear dead, but who knows?


The Panasonic cells on Amazon have never given me trouble. For the remote we ship PK Cell as standard

Hi Sam,

Any chance you could name the seller you buy from? There’s a ton of knock-off batteries being supplied.

Nearly all of the batteries supplied and shipped by Amazon are part of their incredibly limiting ‘add-on item’ scheme (charging 4.80 p&p if you don’t have £20 of amazon-fulfilled items to buy, for batteries costing 2.80, is beyond frustrating)


I just bought a dozen a while back, don’t remember where from. May have in fact been eBay.

I’d send you one in the post but laws on sending batteries not packed with equipment are tough these days


No need to worry about sending a battery, I was just venting (awoke at 4pm, found a letter regarding house insurance renewal, then spent 45 minutes being unhappy on the phone about the unjustified £100 increase this year. I’m tired of companies going out of their way to rip off loyal customers, and making you jump through hoops to get the increases down to a sane level).

That’s why I love your company so much - it actually cares about the customer.

Anyway, I’ll get some brand new batteries and hopefully the remote will be back to fully functional once again.

Take care Sam,

1 Like

In the unlikely event it isn’t, give me a shout.


1 Like

Cheers Sam

Brief update, for completeness:

Remote still working without issue two weeks on, after fitting a battery holding a decent charge (ebay / amazon battery purchases are a total lottery…)


FWIW, I have 3 remotes with various qualities of fit of the battery cover. The worst one (which was replaced with no RMA) still gets a lot of use but stops occasionally. A squeeze of the battery cover always brings it back to life and no need to use two hands from then on. Battery is still good 18 months later.

1 Like