Vero 4k+ remote misses keypresses

Can anyone help? My Vero 4k+ remote has started acting erratically.
Registers some key presses and misses others. Sometimes I have to hit a button several times before it registered. Ive tried 2 brand new batteries, and have tried the reset procedure that Sam suggested on an older thread.

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on
    Still only works intermittently. I can see the blue light at the transmitter when I hit the buttons, but they’re not always registered at the Vero box.
    Any suggestions?

Try the other USB port on the Vero.

Is anything else connected to the Vero via USB?

Moved the dongle to the front USB port, and so far all seems better.
Strange, I’m pretty sure I tried that earlier when I was troubleshooting.
I’ll keep it there and play with it for a while.
There’s no other USB devices connected to the Vero.

Edit - Nope it’s started playing up again. Seems to wander off for a couple of seconds after a few keypresses. its really frustrating to scroll through large lists.

Using HDMI-CEC is fine, though.

Logs in case it helps -

Is it maybe picking up interference from some nearby device such as a wireless router or access point?

Possibly. Never thought of that. Ill move it and check again

That’s a bingo!
Moved it to the other side of my UHD player further from the router and its all good now.