Vero 4k Remote stoped working and resolution change hangs kodi

Hi there,

I had some problems lately with my Vero 4K:

It didn’t boot up, remained in a 2 or 3 secs loop forever, reading the forums I thought might be a PSU problem and it was indeed, a new PSU worked.
After that I reinstalled OSMC via SD and now I am facing 2 problems:

  • Remote stop working, I did the pairing steps: blue led is flashing 3 times after connecting the dongle but after turn off and on Vero is still not working

  • Try to change resolution (using a keyboard) from 1920x1080i to 1920x1080p or 4Kp just freezes OSMC.

Here are the logs: (cannot upload the logs after changing resolution since the box is frozen)

I hope someone can help :slight_smile:

Did you restore a Kodi backup from another device?

Can you try the remote dongle in the other USB port?


Kodi keeps trying to recognise the remote dongle. If you remove the dongle and just use a keyboard does it work?

I did not create a backup nor I tried to restore one.
I tried both USB ports but not success

Yes ! display configuration works just fine after unplug the dongle :+1:
Probably that narrows a little the root cause of the problem cc @sam_nazarko
Thank you !

If you plug the dongle back in, what happens?

Nothing that I can notice.

Does the dongle work normally on another device, such as a PC?


Thank you Sam,

Yes, it looks faulty. Windows goes into a loop of detecting and lost new usb keyboard very rapidly.
Is it possible to get just a new dongle for the remote ?

No, the remote control that came with the OSMC Vero 4k is no longer manufactured.
The new OSMC remote control has buttons for adjusting the volume instead of the forward and rewind buttons. You can find this in the OSMC shop, see above in the menu bar of this page.

Got it, thank you.