Vero 4K - remote stopped working

Hi Guys,

Help me, my beloved 4k’s remote just stopped working!
Replaced the battery … doesn’t work.
Tried re-pairing them, no luck…
Remotes LED does long light-ups, without any affect on the Vero …
I’m a mac user, plugged it onto my MBP, showed up as IR receiver in system profiler, can’t pair either :S

The receiver may need replacing. You can open a support request about this.

Is it common?
I mean, if yes, I’ll buy a handful of those :smiley:

No, it’s not common based on the number of remotes we ship.

After re-reading, I’m not certain that the issue is even your receiver if it’s being detected in the MacBook.

More likely a problem with the remote? Has it been dropped recently?

It also goes without saying that we don’t sell receivers. If the unit is faulty and the warranty is valid they are replaced free of charge.



Nope, no drop or anything like that, it worked like a charm and just stopped :s
I’m pretty sure I’m out of the warranty, I bought this years ago, like two, or more…

Does it have volume buttons or fast forward / rewind buttons?
Just getting an idea of the age of it…

It has the fast forward buttons, I guess it is generation 1.
Worked like a charm…love it actually :wink:

You’re right. It’s a Very 4K (no plus).

Do you see a blue light emit from the top of the remote when you press a button?

The Vero 4K shipped with the 2nd generation OSMC RF from November 2017, with it being officially announced in January 2018.

The receiver is likely defective, but we don’t make them for the old model. I’ll get this solved for you though – see PM