Vero 4k - slow connection speed


I’m using Vero 4k for about 3 days. It is super fast when I watching all kinds of movies from Hard drive but…
When I try to open Youtube videos or some streams from all kind of services it is very slow…
My Libreelec Wetek Core was super fast.
I tried cable and Wifi connection.
The longest time is to load movie from click to open. When it is open I can rewind and skip it forward almost immediately.
I tried also transmiision and I think speed was ok (from 0,5MB/s to 6MB/s - I have 250 Mbit).
I think there is some problem with starting new source…when it is loaded it works super fast.
Any advice?

Best regards

Where are you downloading to? An external drive?
Keep in mind that torrent speeds vary per torrent. You could try a legitimate source, such as a Ubuntu ISO which will be highly seeded to see if that works better. You may also need to adjust some Transmission settings.

A debug log might be helpful for that.

Has anyone used YouTube recently and found it slow on Vero 4K?


Hi Sam
Thx for answer
I said that I think Transmission speed was ok. This is not a problem.
I have impression that each operatian that need internet connection is slow.
When I try to download subtitles with opensubtitles or any other services I must wait for about 10-15 s. On my wetek core it was 2-5 s.
When I try to open any Youtube clip also 10-15 s. Wetek 5-7s.
When I install addons it tooks to long.
Vetek 4k is very quick when watching movies and sound passthrough to aplifier is amazing. The most amazing thing is auto refresh rate for 24, 50, 60 an 23,97 movies but…
I think there is a small issue with opening new internet streams like Youtube and etc…
Best regards

Perhaps you have some DNS resolution problems. I would recommend providing some logs so we can investigate this further.

Thx for answer Sam

I test it for some more time…
If the problem persist I will make some logs.

Best regards

For sure there is some problem with internet connection and speed in Vero 4k. I ty wifi and cable. DHCP and manual. Different DNS and everything works so sloooooooow. It is not normal! My every other device in home wifi works very fast. My wetek core opens streams and youtube in seconds. Today on vero I wait 40s to play any Youtube video!
Something is not alright.
Any sugestion what to do before I send You logs?

Best regards

We need logs to see what the issue is


My log showing how long I mus wait to open Youtube video.

Best regards

Are you using WiFi or Wired? Which one would you prefer to use?

You could try the Speedtest Kodi add-on to check your connection speed first.


I try WiFi and Wired. I prefer Wired. I tried and something is very wrong:
Download 0,65 Mbs
Upload - 1,68 Mbps

I tried Wired

I have 250Mbit/20Mbit
All my devices in my home are working ok.

Yes, that’s not right at all. It’s why you’re having speed problems.

Let’s start with Wired as it’s the easiest to troubleshoot and won’t have as many variables as WiFi has.

  • Is the Ethernet cable plugged in to the same router / switch as other devices?
  • Is Transmission running in the background? Can you try stop it in My OSMC -> Services to see if it improves things?

I can see that local network connectivity seems OK, but there are problems with the Internet. For example, clock synchronisation fails:

Jan 16 19:38:15 osmc http-time[402]: No internet connectivity was detected within 60 seconds. Will try to send time query anyway.

Do you access any shares on your computer? Are they working at a reasonable / standard speed?

If you’re familiar with SSH we can do some digging and probably resolve this quite quickly. It’s odd that you experience this problem on both WiFi and Wired Ethernet.


Hi Sam

As always many thanks for such quick answer.
I restarted my router and everything is ok now :slight_smile:
It is weird becouse all other devices was working ok…only Vero not.
But after restart ping 65, Download 45 and 19 upload. It is ok.
Sorry I bother You and I did not do the obvious thing at the beginning .
Once again:
Vero 4k is the best video player in the market!
Best regards

I wonder if your router’s NAT table got borked by the torrents

It is very likely…I was using Transmission 3 days ago.